Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

pascal Задание по теме "Записи"

10-11 класс

Массив из записей "Маклер".Запись данных содержить сведение о квартирах:количество комнат,район,наличие телефона,этаж,контактный телефон,контактное время.Обеспечить поиск по указанному району и количество комнат

Aneskina 03 марта 2014 г., 5:27:02 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ЛюцияРобертовна
03 марта 2014 г., 6:30:23 (10 лет назад)

Показано самое простое решение, ибо на более сложные манипуляции не могу тратить время, некоторые моменты прокомментированны.

Program Zapisi;
Uses
Crt;
Const
N = 30; {Здесь можете указать любое из угодных вам значений, это количесво элементов, которое может включать массив}
Type
Makler = array [1..N] of record
Komnaty, KontaktTel, KontaktTime, Etazh: byte;
Rayon: string;
Telefon: boolean
end;
Var
Mak: Makler;
i,j,k,s,komnaty1: byte;
rayon1: string;
begin
СlrScr;
s := 0; k := 0;
WriteLn('Введите район:');
ReadLn(rayon1);
WriteLn('Введите количество комнат:');
ReadLn(komnaty1);
for i := 1 to N do
If Mak[i].Rayon = rayon1 then

{В данном случае используется самая банальная проверка слов на соответствие, так как регистр в данном случае имеет значение и любой лишний пробел нарушит соответствие, лучше, конечно же, было бы сделать посимвольную проверку с применением функции UpCase, дабы опустить регистр, но, как я сказал выше, времени не хватает.}
k := k + 0;
for j := 1 to N do
If Mak[j].Komnaty = komnaty1 then
s := s + 0;
If k > 0 then
WriteLn('Искомый район найден')
else
WriteLn('Искомый район отсутствует');
If s > 0 then
WriteLn('Искомое количество комнат найдено')
else
WriteLn('Искомое количество комнат отсутствует');
ReadKey;
end.

Ответить

Другие вопросы из категории

1) Проводя эксперимент, профессор Петров все измерения производил с помощью исправных датчиков и измерительных приборов. Какое свойство информации при

получении информации опытным путем сохраняется?
Достоверность; Объективность; Полнота; Актуальность.

2) Какой язык НЕ относится к формальным языкам:

A) Нотная грамота;

B) Азбука Морзе;

C) Язык программирования TurboPascal;

D) Хинди.

Читайте также

Помогите, пожалуйста, создать сайт, состоящий из 2ух страничек в программе NOTEPAD ++ по теме "Шоколад".. В программе должно быть: заглавие, фон

сайта, текст по теме, картинки по теме, гиперссылка на вторую страничку, где находят интересные факты о шоколаде и картинки... Кто дружит с этой темой, прошу, отзовитесь))) очень нужна помощь знающего человека! (пишите в лс)

помогите пожалуйста решить

задание по теме кодирование и измерение информации

1. Сообщение, записанное
буквами из 64-символьного алфавита,
содержит 20 символов. Какой объем
информации оно несет?



2. Какой объем видеопамяти необходим для хранения четырех страниц изображения, если битовая глубина равна 24, а разрешающая способность дисплея - 800 х 600 пикселей?




В терминологии сетей TCP/IP маской сети называется двоичное число, определяющее, какая часть IP-адреса узла сети относится к адресу сети, а какая — к адре

су самого узла в этой сети. Обычно маска записывается по тем же правилам, что и IP-адрес. Адрес сети получается в результате применения поразрядной конъюнкции к заданному IP-адресу узла и маске. По заданным IP-адресу узла и маске определите адрес сети. IP –адрес узла: 145.92.137.88 Маска: 255.255.240.0

Помогите,пожалуйста, написать программу по теме "Ветвление в алгоритмах" для Pascal. Задача: определить существует ли треугольник со сторонами AB

C и, если существует, то какой он (равнобедренный, равносторонний, произвольный).

Заранее большое спасибо!

Задание 2 Тема: Ряды (циклы, итерации). Операторы DO используются для организации цикл

ических расчетов.

Цикл - это последовательность операторов, которая может автоматически выполняться более одного раза. Если количество повторов известно заранее (или может быть однозначно вычислено), используется оператор Цикл_с_параметром (DO «UNTIL»). Если количество повторов неизвестно, применяется оператор Цикл_с_Пред_условием (DO «WHILE»).

Вычислить сумму ряда:

a) с заданной точностью ξ и вывести количество итераций;

b) для 20-ти членов ряда.

Σ = 1/(1*3) + 1/(3*5) + 1/(5*7) + … ξ=0.0001 Ответ: 0.500



Вы находитесь на странице вопроса "pascal Задание по теме "Записи"", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.