Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задание 2 Тема: Ряды (циклы, итерации). Операторы DO используются для организации цикл

10-11 класс

ических расчетов.

Цикл - это последовательность операторов, которая может автоматически выполняться более одного раза. Если количество повторов известно заранее (или может быть однозначно вычислено), используется оператор Цикл_с_параметром (DO «UNTIL»). Если количество повторов неизвестно, применяется оператор Цикл_с_Пред_условием (DO «WHILE»).

Вычислить сумму ряда:

a) с заданной точностью ξ и вывести количество итераций;

b) для 20-ти членов ряда.

Σ = 1/(1*3) + 1/(3*5) + 1/(5*7) + … ξ=0.0001 Ответ: 0.500

Elizabet2804 16 июля 2014 г., 10:26:46 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
100galina
16 июля 2014 г., 12:11:50 (9 лет назад)

var a:real;
i,p,i1,i2,e:longint;
begin
i1:=1; i2:=3;
read(e);
for i:=1 to 20 do
begin
a:=a+1/(i1*i2);
inc(p);
i1:=i1+2; i2:=i2+2;
end;
writeln('Сумма ряда ', a:2:e);
writeln('Кол-во итераций ',p);
end.

+ 0 -
Танюшка85
16 июля 2014 г., 14:31:24 (9 лет назад)

Нужно написать программу))

Ответить

Другие вопросы из категории

Читайте также

СРОЧНО!!! Помогите пожалуйста с турбо паскаль, задание на тему циклы....

Как мне препод объясняла там должно быть for i:=1 to N do begin
P:P*(2*i)/(2*i+1)
end;
Вот часть которую нужно как то применить к этому заданию...
Как будет выглядеть весь код?)))

Выбрать правильный ответ. Многократно повторяющаяся часть программы (алгоритма) называется: Циклом; Логическим условием; Оператором;

Ничего из вышеперечисленного.

Бесконечный цикл: Можно остановить путем ввода данных пользователем; Приводит к останову программы Можно использовать для создания короткой паузы в выполнении программы; Приводит к повторению некоторой части программы, пока не будет нажата клавиша “СТОП”.

Можно организовать цикл, повторяющийся до тех пор, пока не выполнится логическое условие с помощью операторов: FOR … NEXT IF… THEN GOTO Все вышеперечисленное.

Содержащаяся одна в другой циклические структуры называются: Вложенными; Простыми; Последовательными; Ничего из вышеперечисленного.

Какая из следующих строк может быть начальной строкой цикла FOR…NEXT: FOR A$=1 TO 15 FOR A=1 TO 15 FOR A=1 TO=15 FOR 4A=1 TO 15

Цикл FOR…NEXT приводит к повторению некоторой части программы, которая носит название: Тело цикла; Глубина цикла; Параметр цикла; Приращение.

Найти сумму произведений a и b. a, b вводятся в цикле их 4 пары. Блок-схема.

Объясните пожалуйста еще цикл for to do и счетчик, для чего он служит.

Помогите исправить ошибки Задание: составить программу на яз. Паскаль с использованием цикла с неизвестным числом повторений для вычислений значения

функции F(x)=sin(x)+tg(x) на отрезке [А, В] при изменении аргумента в точках хi = А+iН, где Н – шаг. А=1, В=2, Н=0,125.

Листинг программы:

Program Tabulir;

Var x, y: real;

Begin x:=1;

While x≤2 do begin

y:=sin(x)+tg(x);

writeln (x:9:1, y:16:3);

x:=x+0,125;

End.



Вы находитесь на странице вопроса "Задание 2 Тема: Ряды (циклы, итерации). Операторы DO используются для организации цикл", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.