Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Найти сумму произведений a и b. a, b вводятся в цикле их 4 пары. Блок-схема.

10-11 класс

Объясните пожалуйста еще цикл for to do и счетчик, для чего он служит.

LE05RA02 30 нояб. 2013 г., 12:22:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
твдамс
30 нояб. 2013 г., 13:51:16 (10 лет назад)

Вот текст программы на языке Паскаль.

program p1;
var a,b,c,i:integer;
begin
c:=0;

for i:=1 to 4 do
 begin
 read(a,b);
 c:=c+(a*b);
 end;
write(c);
end.

Счётчик служит для запоминания промежуточных результатов работы программы, в данном случае он суммирует произведения.

Ответить

Другие вопросы из категории

15. Определите

результат выполнения программы:


var
i, sum: integer;

Полностью заполненного картриджа лазерного принтера хватает, чтобы распечатать 1600 страниц при трехпроцентном заполнении страницы. После включения

режима экономии тонера можно распечатать на 20% страниц больше. Сколько страниц можно распечатать в этом режиме с помощью картриджа, который заправлен на 50%?
а) 480

б) 960

в) 1920

г) 2000

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

модуль srt не найден в паскале как исправить вот код

program prim_3;
uses srt;
Label 1;
const
Sob='Вам доступны базы';
var
p:integer;
otv:0..1;
begin
1:clrscr;
Writeln ('Введите ваш пароль');
Readln (p);
clrscr;
gotoxy (10,8);
case p of
1747: Writeln (sob,' A,B,C');
3331,7922: Writeln (sob,' B,C');
8927..9455: Writeln (sob,' C');
else
Writeln ('У вас нет права доступа к базам данных');
end;
gotoxy(15,10);
Writeln ('Будете продолжать работу ''Да-1,Нет-0' );
Readln (otv);
if otv=1 then goto 1;
end.

Читайте также

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов

от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и произведение отриц.

Помогите решить, пожалуйста! Хотя бы некоторые задачи.

1. Найти сумму (произведение) элементов 1-й строки (столбца) массива Т (6,4).
2. Заполните матрицу, элементами которой является произведение номеров строк и столбцов соответствующих элементов.
3. Вычислить сумму и произведения элементов матрицы Z (4,6).
4. Вычислить сумму и произведение элементов матрицы А(5,5).
Язык программирования - Pascal.

1)Найти 3 совершенное число(программа+блок схемы)

2)Определить 35 простое число(программа +блок схемы)
3)Дано:трехзначное число ,определить :является ли произведение его цифр трехзначным числом(программа+блок схемы)

матрицу10 на 10 заполнить случайными однозначными числами вывести на экран.

Наити:1.количество четных чисел элементов матрицы
2.количество нечетных чисел элементов матрицы
3.сумму чисел диагонали матрицы
4.максимальный элемент матрицы и его адрес.
Написать блок схему и программу



Вы находитесь на странице вопроса "Найти сумму произведений a и b. a, b вводятся в цикле их 4 пары. Блок-схема.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.