Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Определить попадает ли точка в заданный диапазон. Написать программу.Pascal

10-11 класс

Nastya460 23 янв. 2017 г., 11:53:42 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AlExAnDrA2123
23 янв. 2017 г., 14:48:19 (7 лет назад)

var x,y,r:real;
begin
read(x,y,r);
if (x>=0) and (y>=0) and (x^2+y^2<=r^2) and (x<=0) and (y<=0) and (x+y>= -r) then write('попадает') else write('нет');
end.

+ 0 -
Nikalex991
23 янв. 2017 г., 16:23:58 (7 лет назад)

var
    x, y, r: real;

begin
    read(x, y, r);
    if ((x >= 0) and (y >= 0) and (x * x + y * y <= r * r))
        or ((x < 0) and (y < 0) and (x + y >= -r)) then
        write('да')
    else
        write('нет');
end.

Ответить

Читайте также

Написать программу, которой передаются координаты точки (x,

y) и которая определяет, попадает ли точка в заштрихованную область на рисунке,
который соответствует Вашему варианту. Попадание на границу области считать
попаданием в область.

Написать программу на Pascal

определить попадает ли точка A(x,y) внутрь треугольника, углы которого заданы координатами (0,2), (-2,0), (2,0)



Вы находитесь на странице вопроса "Определить попадает ли точка в заданный диапазон. Написать программу.Pascal", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.