Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Нужно написать программу на Паскале используя процедуру.

10-11 класс

Условие: Найти и вывести максимальный элемент кратный N.
N вводится с клавиатуры.

Doinaneagu 24 июня 2013 г., 18:01:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AUTOZONE2003
24 июня 2013 г., 20:12:43 (10 лет назад)

const
  m = 20;

type
  V = array[1..m] of integer;

function MMax(a: V; n: integer): integer;
var
  i, mm: integer;
begin
  mm := -1000;
  i := n;
  while i <= m do
  begin
    if mm < a[i] then mm := a[i];
    i := i + n
  end;
  Result := mm
end;

var
  A: V;
  i, n: integer;

begin
  Randomize;
  write('Введите значение N: ');
  readln(n);
  writeln('Значения элементов массива:');
  for i := 1 to m do
  begin
    A[i] := Random(100) - 50;
    write(A[i]:4);
  end;
  writeln;
  writeln('Максимальный элемент, с номером, кратным ', n, ': ', MMax(A, n))
end.

Тестовое решение:

Введите значение N: 3
Значения элементов массива:
 -11 -47   0  43  -8  28  33 -43   1  47  45 -15   7 -49 -28  20  49 -46  44 -44
Максимальный элемент, с номером, кратным 3: 28


+ 0 -
Mr24Hamster
24 июня 2013 г., 21:47:00 (10 лет назад)

Комментарий удален

+ 0 -
Милена05
24 июня 2013 г., 23:42:26 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

1. Что такое объект?2. Что такое система?3. Что такое общее имя объекта? Приведите пример.4. Что такое единичное имя объекта? Приведите пример.5.

Приведите пример природной системы.6. Приведите пример технической системы.7. Приведите пример смешанной системы.8. Приведите пример нематериальной системы.9. Что такое классификация?10. Что такое класс объектов?

Задание №4. Решите задачу:

Имеется рисунок в 24-разрядном формате BMP. Вычислите, какой объем (Кбайт, Мбайт) на носителе займет этот рисунок, если экран содержит 600*800 точек.

Читайте также

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!



Вы находитесь на странице вопроса "Нужно написать программу на Паскале используя процедуру.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.