Помогите пожалуйста написать программы на языке Паскаль н 12, под всеми буквами. Очень нужно!!!
10-11 класс
|


var i,n,c:integer;
begin
c:=1;
readln(n);
writeln('Сумма первых чисел: ', (1+n)*n/2);
writeln('Сумма квадратов: ',(n*(n+1)*(2*n+1))/6);
for i:=1 to n do
if i mod 2=0 then c:=c+i;
writeln('Сумма четных чисел: ',c);
c:=0;
for i:=10 to 99 do
c:=c+i;
writeln('Сумма всех двузначных чисел: ',c);
readln;
end.
Дано:
n - кол-во раз
i, c - счетчик
Найти:
напечатать
мат. модель:
печатать сумму первых n членов
печатать сумму квадратов
для i:= 1 до n
печатать с
для i:=10 до 99
печатать c
Другие вопросы из категории
Имеется рисунок в 24-разрядном формате BMP. Вычислите, какой объем (Кбайт, Мбайт) на носителе займет этот рисунок, если экран содержит 600*800 точек.
план работы.
1. условие задачи
2.математическая модель
3.список переменных с их расшифровкой
4.блок-схема алгоритма
5.программный код
Входные данные:
В первой строке входного потока содержится число A, во второй – число B (0 <= A <= 10100), (1 <= B <= 10000).
Выходные данные:
Выведите единственное число: ответ на задачу.
Очень огромные числа, поэтому просто перемножить их, как видно, нельзя)
Читайте также
добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.
задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов
Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.
заранее огромное спасибо всем!
1,Найти
наименьший элемент массива (начиная с k-го) и
его порядковый номер. Поменять местами k-тый и найденный минимальный элемент.
доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).
ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.
я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.
заранее огромное спасибо всем за помощь!!!
углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.
значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)