Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить циклический процесс определения произведения натуральных чисел (факториал) 1*2*3 *n, для произвольного n (n!)

10-11 класс

план работы.
1. условие задачи
2.математическая модель
3.список переменных с их расшифровкой
4.блок-схема алгоритма
5.программный код

Bogdanyaremkoo 14 февр. 2017 г., 23:31:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikavan24
15 февр. 2017 г., 0:04:22 (7 лет назад)

1. Есть 
2. 5!=1*2*3*4*5=120\\6!=1*2*3*4*5*6=720
3. n - заданное число, y - факториал числа, i - счётчик
4. Прил.
5. 
var
  y: System.uint64; //Большая цифра же и положительная
  n, i: byte; //Нет смысла большие числа брать слишком, переполнение будет

begin
  readln(n); //Принимаем число...
  y := 1;
  i := 1;
  repeat
    y := y * i; //...и умножаем такое-то количество раз
    i := i + 1;
  until i > n;
  if (y = 0) then //Выводим, предусмотрев переполнение
    writeln('Слишком большая цЫферка')
  else
    writeln(y);
end.

Ответить

Другие вопросы из категории

Даны числа A и B. Вывести их произведение A × B.

Входные данные:
В первой строке входного потока содержится число A, во второй – число B (0 <= A <= 10100), (1 <= B <= 10000).

Выходные данные:
Выведите единственное число: ответ на задачу.

Очень огромные числа, поэтому просто перемножить их, как видно, нельзя)

Читайте также

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.

Помогиииитееее!!!!

на паскале
1.Найти сумму первых 10 натуральных нечетных чисел.
2.Найти произведение натуральных чисел прекратить подсчет при вводе 1.



Вы находитесь на странице вопроса "Составить циклический процесс определения произведения натуральных чисел (факториал) 1*2*3 *n, для произвольного n (n!)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.