Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Массив 5 на 5 заполняется случайными числами от 0 до 99 в каждой строке массива найти минимальное значение . Паскаль. Помогите пожалуйста в течение 10 мин

5-9 класс

Innanastasiya 02 марта 2014 г., 11:27:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nикa
02 марта 2014 г., 12:57:35 (10 лет назад)

var
  a: array [1..5, 1..5] of byte;
  min: array [1..5] of byte;
  i, j: byte;

begin
  for i := 1 to 5 do min[i] := 100;
  for i := 1 to 5 do
    for j := 1 to 5 do
    begin
      a[i, j] := random(0, 99);
      if (min[i] > a[i, j]) then min[i] := a[i, j];
    end;
      
  for i := 1 to 5 do
  begin
    for j := 1 to 5 do
      write(a[i, j]:2, ' ');
    writeln('- ', min[i]);
  end;
end.

Ответить

Другие вопросы из категории

кто создал фейсбук!!!!!!!!
Файл размером 9 Кбайт передаётся через некоторое соединение со

скоростью 1536 бит в секунду. Определите размер файла (в байтах),
который можно передать за то же время через другое соединение со
скоростью 512 бит в секунду.
В ответе укажите одно число — размер файла в байтах. Единицы
измерения писать не нужно.

Выберите из списка информационные процессы(действия с информацией):

А) разговор по телефону
Б) письмо приятелю

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99.

Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано". Дается 10 попыток. Программа завершается, если дан правильный ответ или попытки закончились.

На планете Триа использую только числа от 1 до 27. Их записывают с помощью символов «<»,«.» и

«>». Запись числа N выполняется по следующему алгоритму:

1) весь интервал (1..27) делится на 3 равные части: от 1 до 9, от 10 до 18 и от 19 до 27.

2) если число N оказалось в первом интервале, записываем символ «<», если во втором­ символ «.», и если в третьем­ – символ «>»

3) делим оставшийся интервал (в который попало число N) на три части и определяем следующий знак кода, который записывается справа от предыдущих

4) повторяем шаги 2 и 3 до тех пор, пока оставшийся интервал не будет содержать одно число.

Например, число 22 будет закодировано как «>.<» (интервалы 19-27, 22-24, 22).

Определите, какое число записывается как «.<>»?



Вы находитесь на странице вопроса "Массив 5 на 5 заполняется случайными числами от 0 до 99 в каждой строке массива найти минимальное значение . Паскаль. Помогите пожалуйста в течение 10 мин", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.