Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Объявлен набор в шк.команду. Известен рост каждого из N учеников,желающих попасть в эту команду. Подсчитайте количество претендентов,имеющих шанс

10-11 класс

попасть в команду,если рост игрока команды должен быть не менее 170см. Считайте рост претендента в команду случайным числом из диапазона от 150 до 300 см, число претендентов n=50.

Nikitos06 09 окт. 2014 г., 14:15:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89245499688
09 окт. 2014 г., 15:40:39 (9 лет назад)

На C++

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

int main()
{
   srand(time(0));
   int counter = 0;
   int growth;

   for(int i = 0; i < 50; i++)
   {
      if((growth = rand() % 151 + 150) >= 170)
      {
         counter++;
      }
      cout << growth << ' ';
   }
   cout << endl << endl;

   cout << counter << " pupil";
   cout << (counter != 1 ? "s" : "") << endl; // Если будет только 1 ученик,
                                             //то больше ничего не печатать
                                             //иначе - допечатать букву "s"

   cin.get();
   return 0;
}

Ответить

Другие вопросы из категории

Какие значения чисел:

0.1E + 05, -33.3E - 4, 25.5E + 0?

Запишите по правилам языка Паскаль такие выражения:
a) 1.5 + 2 (x^2 + bx)
b) 3(x + 5) - x^3
_____________
2x^2 + x

Вычислить значения выражений :
a) 125 mod 30
b) 20 div 6 mod 5

Записать выражения в общепринятой форме:
a) (-2*b+3*b-4*a*c)/3*a

Пусть a, b: integer, c: real. Определите тип выражения (целый или вещественный) :
a) a/b
b) a + b
c) a + c

Чему равны значения переменных x и y после выполнения команд: x:=2 ; y:=5 ; y:=x ; x:=x+1?

Решите, пожалуйста, хоть одно какой-нибудь задание. СРОЧНО НУЖНО!

еще одно пожалуйста , срочно очень надо

у=-(23 в восьмеричной системе счисления+ВА в шестнадцатеричной системе счисления+10101 в двоичной системе счисления) заранее большое спасибо.

Читайте также

Решить задачу средствами Excel: Имеются три участка земли, на которых будут засеяны кукуруза, пшеница, ячмень и просо. Площадь каждого из участков

соответственно равна 600, 180 и 220 га. С учетом наличия семян кукурузой, пшеницей, ячменем и просом следует соответственно засеять 290, 180, 110 и 420 га.
Урожайность каждой из культур для каждого из участков различна и задается матрицей:
40 45 50
30 28 22
18 22 14
24 18 26
Определить сколько гектаров каждой культуры на каждом из участков следует засеять так, чтобы общий сбор зерна был максимальным.

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

Катя, Наташа, Римма и Лиля – студентки факультета иностранных языков – увлекаются музыкой и каждая из них играет на каком-нибудь инструменте, но только на

одном: гитаре, скрипке, арфе или фортепиано.

Каждая из них учится на одном из отделений факультета: английского, французского, немецкого или испанского языка.

Та из них, которая играет на гитаре, учится на отделении испанского языка. Наташа не играет ни на скрипке, ни на арфе, и не учится на отделении английского языка. Катя тоже не играет ни на арфе, ни на скрипке и не учится на отделении английского языка. Студентка отделения немецкого языка не играет на арфе. А Римма учится на отделении французского языка и не играет на скрипке.

На каком инструменте играет и на каком отделении факультета иностранных языков учится каждая из студенток?

получается лилия играет на скрипке и не играется на гитаре, не учится на французском.

рима на французском но не играет на скрипке

наташа не на англйским и не играет не на скрипке не на арфе

катя не на английском не на скрипке не на арфе

Поле шахматной доски представляется парой натуральных чисел, каждое из которых не превосходит восьми: первое число - номер вертикали (при счете снизу

вверх), второе - номер горизонтали (при счете слева направо). Даны натуральные числа k, l, m,n, каждое из которых не превосходит восьми. Требуется:

1. выяснить, являются ли поля (k, l) и (m, n) полями одного цвета

2. на поле (k, l) расположен ферзь. Угрожает ли он полю (m, n)?

задача в Delphi.



Вы находитесь на странице вопроса "Объявлен набор в шк.команду. Известен рост каждого из N учеников,желающих попасть в эту команду. Подсчитайте количество претендентов,имеющих шанс", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.