Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Это программирование, паскаль, нужно написать программу

10-11 класс






Дан одномерный массив A, состоящий из N элементов, N – заданное натуральное
число. Если элементы массива составляют строго монотонную последовательность, то
все положительные элементы массива заменить единицей, иначе оставить массив без
изменения.

Svetlanamityuk 16 янв. 2017 г., 8:52:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Айша05
16 янв. 2017 г., 11:37:30 (7 лет назад)

a:array[1..30000] of integer;
n, i, k, z:integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n do
if (a[i]<a[i+1]) then k:=k+1;
for i:=1 to n do
if (a[i]>a[i+1]) then z:=z+1;
if (k=n) or (z=n) then
for i:=1 to n do
if a[i]>0 then a[i]:=1;
for i:=1 to n do
writeln(a[i]);
readln;
end.

+ 0 -
Theone150713
16 янв. 2017 г., 12:39:48 (7 лет назад)

Это задание полное, ув. товарищ админ

Ответить

Другие вопросы из категории

Над двумя произвольными трехзначными

Над двумя произвольными трехзначными десятичными
числами была произведена операция по следующему правилу: Записывается результат сложения старших разрядов этих
чисел. К нему дописывается результат сложения значений
средних разрядов по такому правилу: если он меньше первой суммы, то полученное
число приписывается к первому слева, иначе – справа. Итоговое число получают приписыванием справа к числу,
полученному после второго шага, сумму значений младших разрядов исходных чисел.

Какое из
перечисленных чисел могло быть построено по этому правилу?

A) 141819
B) 171814
C) 171418
D) 141802

помогите написать на с++
помогите решить срочно

Читайте также

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Написать Программу в паскале которая посчитала бы 5^123 (это цикл как бы должен быть)

http://primat.org/index/0-128 вот сайт что бы написать программу.



Вы находитесь на странице вопроса "Это программирование, паскаль, нужно написать программу", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.