Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дано 4 числа найти сумму чисел, извлечь количество сотен, если четное, то найти среднее этих чисел, а , если нет, то произведение

5-9 класс

606707808909 17 мая 2013 г., 5:01:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Byblik2001
17 мая 2013 г., 7:08:41 (10 лет назад)

program zisla;
uses crt;
var a,b,c,d,s,g,n,v: real;
begin
cls;
write('введите 4 числа');
read(a,b,c,d);
s:=a+b+c+d;
g:=s/100;
if g=g/2 then
begin
v:=s/4;
writeln('среднее этих чисел=',s);
end
else
begin
n:=a*b*c*d;
writeln('произведение этих чисел',n)
end;
end.

решал на паскале абс

Ставь лучшее решение

Ответить

Читайте также

1.С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел.

(Тема:Программирование ветвлящихся и цепленных алгоритмов)
2.Дано двухзначное число,найти сумму и произведение его чисел.
(2-ая задача решается с div и mod)
(Тема:Программирование ветвлящихся и цепленных алгоритмов )

Ребятки!!!!ПОмогите пожалуйста очень срочно!!!! Дан файл f компоненты которого действительные числа.Найти сумму компонентов

файла.Результат поместить в файл g.

дан файл f компоненты которого являются целыми числамию Найти наибольший и наименьший из компонентов файла.результат поместить в файл g

ДАн файл f компоненты которого являются целыми числами найти количество чётных чисел среди компонентов.результат поместить в файл g

Дан файл F компоненты которого являяются целыми числами.записать в файл g все чётных числа файла f

Дан файл F компоненты которого являяются целыми числами переписать компоненты файла f в файл g,так чтобы в файле сначала шли отрицательные а потом положительные числа.

Решить задачу

Даны 3 числа найти сумму 2 наибольших чисел

ПОЖАЛУЙСТА!ПОМОГИТЕ!СРОЧНО!

Решить задачи на турбопаскале:
1.Дано натуральное число Найти сумму и произведение первых двух чисел.
2.Дано n-значное натуральное число. Правда ли что квадрат произведения цифр числа равняется кубу суммы цифр числа.
3.Составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе счисления.



Вы находитесь на странице вопроса "дано 4 числа найти сумму чисел, извлечь количество сотен, если четное, то найти среднее этих чисел, а , если нет, то произведение", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.