Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Написать программу. Ввести одномерный массив из целых чисел. Подсчитать во сколько раз сумма четных чисел массива превосходит среднее арифметическое всех

10-11 класс

чисел массива?

JuliBett 17 июня 2016 г., 0:08:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Netti
17 июня 2016 г., 2:17:07 (7 лет назад)

var a:array[1..1000] of integer;
n,i,s,sum:integer;
arif:real;
begin
write('Vvedite N = ');
read(n);
for i:=1 to n do begin
write('Vvedite a[',i,']=');
read(a[i]);
end;
sum:=0;
for i:=1 to n do begin
if (a[i] mod 2 = 0) then sum:=sum+a[i];
arif:=arif+a[i];
end;
arif:=arif/n;
writeln('Otvet = ',sum/arif);
end.

Ответить

Другие вопросы из категории

умоляю помогите я это не знаю просто это информатика. Вставь пропущенные слова. Кодирование от _____________ отличается тем, что кодируют с целью удобства

___________ и ______________ , а шифруют с целью ___________ смысл сообщения. Данные для справки: срыть, шифрование, хранения, передача.
за ответ даю 150 балов

Читайте также

Дан одномерный массив положительных целых чисел. Последовательно преобразовать этот массив по следующему алгоритму: Находится первый максимальный элемент

и устанавливается первым в массиве, затем из оставшихся находится минимальный элемент и устанавливается вторым в массиве, после чего отыскивается из оставшихся элементов максимальный и устанавливается третьим в массиве и т.д. Размерность массива задается с клавиатуры.
Помогите, пожалуйста, не получается.

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.

(1) вариант

1 написать программу которая вводит с клавиатуры одномерный массив из 10 целых двузначных чисел выводит количество элементов > 28 и их среднее арифметическое
2 написать программу которая выводит с клавиатуры одномерный массив из 6 целых чисел и выводит нечётные
3 написать программу ввода с клавиатуры последовательность целых чисел вычисляющую кол-во и сумму положительно ввёдных чисел



Вы находитесь на странице вопроса "Написать программу. Ввести одномерный массив из целых чисел. Подсчитать во сколько раз сумма четных чисел массива превосходит среднее арифметическое всех", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.