Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ЯЗЫК СИ. Написать программу заполнения односвязного списка значениями и вывода этих значений. Помогите, пожалуйста.

10-11 класс

Timonin123 21 авг. 2013 г., 15:49:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kolpacho
21 авг. 2013 г., 18:03:38 (10 лет назад)

выбирай 

#include <stdio.h>
#include <stdlib.h>  

struct LIST {  
  int number;  
  struct LIST *next; };
  //-----------------------------------------------------------------------------
void Push(struct LIST** list, int number) {    
struct LIST* node = malloc(sizeof(struct LIST));  
  node->number = number;    
 node->next = *list;  
  *list = node; }
//-----------------------------------------------------------------------------
void Print(const struct LIST* list) {  
   if (list) {      
   Print(list->next);    
     printf("%d ", list->number);     } }
//-----------------------------------------------------------------------------  
int main() {  
  int i = 10;  
  struct LIST* list = NULL;
      while (i--) {      
  Push(&list, i + 1);     }  

+ 0 -
Ryazanowadiana
21 авг. 2013 г., 18:59:17 (10 лет назад)

В общем-то типовая задача, посмотрите в Интернет, быстрее будет.

Ответить

Другие вопросы из категории

Сколько различных решений имеет уравнение

J ^ (¬K V K) ^ (¬M V M) ^ (L V ¬L) = 0

Составить программу в Паскале:

Найти наибольшее целое n такое что :
a) 3n^4-730n<5
b) e^n-1000Ln*n<=10

Читайте также

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

1. написать программу, вычисляющую значение функции y=x-24

2. написать программу, вычисляющую значение функции (y=f(x))
y=x-2, если x>0,
y=0, если x=0,
y=x*x, если x<0

1. написать программу, производящее "неформатный" вывод разных значений

2. написать программу, производящее "форматный" вывод разных значений
3. написать программу использующие процедуру writeln c параметрами и без параметров

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.



Вы находитесь на странице вопроса "ЯЗЫК СИ. Написать программу заполнения односвязного списка значениями и вывода этих значений. Помогите, пожалуйста.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.