Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В Pascal ABC составить программу для подсчета четных цифр, используемых для записи произвольного числа X.

5-9 класс

использовать цикл с предусловием, другого не проходили
ОЧЕНЬ СРОЧНО ПОЖАЛУЙСТА!!!!!

Ogirksusha 07 июля 2013 г., 3:52:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marinapashkova
07 июля 2013 г., 6:31:56 (10 лет назад)

program red;
var a,b:integer;
begin
b:=0;
readln(a);
if a<10 then
begin
if a mod 2=0 then b:=1;
end;
if (a>=10) and (a<100) then
begin
if ((a div 10) mod 2=0) and (a div 10 <>0) then b:=b+1;
if ((a mod 10) mod 2=0) and (a mod 10 <>0) then b:=b+1;
end;
if (a>=100) and (a<1000) then
begin
if ((a div 100) mod 2=0) and (a div 100 <>0) then b:=b+1;
if (((a div 10) mod 10) mod 2=0) and ((a div 10) mod 10 <>0) then b:=b+1;
if ((a mod 10) mod 2=0) and (a mod 10<>0) then b:=b+1;
end;
writeln(b);
end.

Ответить

Другие вопросы из категории

Укажите верный электронный адрес из представленных: Выберите один ответ. A. Miru [email protected] /* */ B. Мир@tenet.ru C.

[email protected]

D. tenet.edu@Mir E. [email protected]

Автомат получает на вход трёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам.

1. Вычисляются два числа – сумма старшего и среднего разрядов, а также сумма среднего и младшего разрядов заданного числа.
2. Полученные два числа записываются друг за другом в порядке не возрастания (без разделителей).
Пример. Исходное число: 277. Поразрядные суммы: 9, 14. Результат: 149.

Определите, сколько из приведённых ниже чисел могут получиться в результате работы автомата.1616 169 163 1916 1619 316 916 116
В ответе запишите только количество чисел.

Помогите пожалуйста! Задание очень интересное, но у меня оно не получается!!!

1) Сколько Гб информации содержит сообщение объемом 5684 Мб + 1785 бит ? Точность ответа - 2 знака после запятой. Ответ: Гб.
2) Имеется 24 файла, каждый имеет информационный объём 240 Мб. Укажите минимальный информационный объём носителя, необходимый для хранения этих файлов. Объём носителя укажите в Кб. Ответ: Кб.
3) Сколько бит информации содержит сообщение объемом 5684 Б + 1,2 Мб ? Ответ: Бит.
4) 1234 однотипных файла размещены на носителе ёмкостью 32 Гб. После размещения их на носителе осталось 56321 Б свободного места. Укажите информационный вес одного файла в Мб. Точность ответа - 2 знака после запятой. Ответ: Мб.
5) Сколько символов содержит сообщение ёмкость 5 Мб, если знать, что каждый символ имеет информационный вес 16 бит. Ответ: символов.
6) Сколько Кб информации содержит сообщение объемом 12345678 бит + 1 Мб? Точность ответа - 2 знака после запятой. Ответ: Кб.

Читайте также

Помогите пожалуйста.

составьте алгоритм для определенного количества цифр в записи натурального числа

Очень срочно, и очень нужно составить программы по информатике PASCAL ABC, помогите, пожалуйста от этих программ зависит моя четвертная.

1. Составьте программу для определения большего из двух чисел х или у
2. Составьте программу для нахождения площади прямоугольника по заданным сторонам а и б

1. Составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из Лондона в Нью-Йорк, если в самолете три

четверти пассажиров имеют билеты первого класса, стоимостью Х рублей за каждый. Остальные пассажиры имеют билеты второго класса, которые дешевле на 20%
2.Составьте программу определения стоимости набора конфет, в которой находятся следущие сорта:
Наименование: Количество: Цена,руб:
Красная шапочка 500 г k
Алые паруса 200 г a
Воронежские 100 г b
Чародейка 250 г m



Вы находитесь на странице вопроса "В Pascal ABC составить программу для подсчета четных цифр, используемых для записи произвольного числа X.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.