Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вводится число. Напечатать YES, если оно является степенью двойки, NO - иначе.

5-9 класс

Nike2hnije 15 дек. 2013 г., 16:57:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
BellaProf
15 дек. 2013 г., 18:32:57 (10 лет назад)

Program x2;
var n:longint;
begin
Write('Введите n, n = ');
Readln(n);
While n mod 2 = 0 do 
    n:= n div 2;
If n=1 then Write('YES')   
     else write('NO');
end.

Ответить

Другие вопросы из категории

Прошу, помогите! Задачи на тему - линейные алгоритмы. 1)От станции до озера S км.Туристы, направляясь от станции к озеру, полтора часа шли пешком со

скоростью А км/ч, а затем сели на попутную машину, которая ехала со скоростью В км/ч. За какое время туристы добрались до озера? 2)В школьном коридоре длиной 56 м нужно выкрасить пол. Выкрасив часть коридора длиной 22 м, израсходовали А кг краски. Сколько ещё нужно краски, чтобы докрасить пол? 3)Чтобы сварить 4 порции пшенной каши, нужно взять 220 г пшена, 1 л молока и зо г сахара. Сколько потребуется этих продуктов, чтобы сварить N порций каши? Плиииз помогите. Меня на этой теме не было и ничего не понимаю!

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

3 3 3 3=7 как??? помогите плиз!!!

Читайте также

Где ошибка? Является ли заданное натуральное четырехзначное число палиндромом?Палиндромами называются числа, которые читаются одинаково

слева-направо и справа-налево.
Напрмер, 8998, 3333.
Вводится целое число N (999 < N <10 000).
Вывести слово YES, если N является палиндромом и NO, если нет.

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

Информатика "Программирование разветвляющихся алгоритмов" 1. Увеличить число X на 10, если оно положительное,

во всех остальных случаях уменьшить на 10.

2. Увеличить число X на 5, если оно положительное.



Вы находитесь на странице вопроса "Вводится число. Напечатать YES, если оно является степенью двойки, NO - иначе.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.