Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите!Укажите фрагменты программ, при выполнении которых значение переменной k будет одинаковым?(на картинке)

10-11 класс

ReginaK123 10 мая 2015 г., 16:06:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Inessa0999
10 мая 2015 г., 17:53:16 (9 лет назад)

если (n > p), то равны в 1,3 и 4
если (n = p), то равны в 1 и 2
если (n < p), то равны в 1 и 2

Ответить

Читайте также

Требовалось написать программу,при выполнении которой с клавиатуры вводится натуральное число,не превосходящее 10^8, и выводится его первая цифра.Ученик

написал такую программу:
var n:longint;
begin
read(n);
while n>10 do
begin
n:=n mod 10
end;
write(n);
end.


1)Напишите,что выведет эта программа при вводе числа 1984.
2)Приведите пример числа,при вводе которого программа выдаст верный ответ.
3)Найдите в программе все ошибки.

НАПИСАТЬ ПРОГРАММУ!ПОМОГИТЕ!!!

while и repeat
1)напечатать все отрицательные числа из диапазона от а до б, с шагом h.
2)Напишите программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10^9, и выводится сумма четных цифр этого числа и 0, если таких цифр в числе нет

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

1)Определите значение переменной c после выполнения следующего фрагмента программы:

a :=40 ;
b := 10;
a := - a / 2*b,;
if a > b then
c := b - a
else c := a - 2 * b

2)Определите значение переменной c после выполнения следующего фрагмента программы:
a := 5;
a := a + 6;
b := - a;
c := a - 2 * b



Вы находитесь на странице вопроса "Помогите!Укажите фрагменты программ, при выполнении которых значение переменной k будет одинаковым?(на картинке)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.