Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Pascal: Дана строка. Слова разделены пробелами. Определить количество слов заданной длины

10-11 класс

5геоквьта 11 дек. 2016 г., 8:07:19 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Liana234
11 дек. 2016 г., 9:52:23 (7 лет назад)

Program Stroka 

uses Сrt;
var s,temp:string;
       i,c,k,d:integer;
begin
     clrscr;
     write('Введите строку:');
     readln(s);
    write('Введите  длину:');
    readln(k);
   temp:=''; c:=0;

 

d:=length(s);
for i:=1 to d do
     begin
          if s[i]<>' ' then temp:=temp+s[i];
         if ((s[i]=' ') or (i=d)) and (temp<>'') then
begin
     if Length(temp)=k then c:=c+1;
     temp:='';
   end;

end;
   writeln('Количество слов заданной длины: ',c);

    readkey;
end.

 

 

 

Ответить

Другие вопросы из категории

Тема "Массивы и двумерные массивы"

Задачи:
- N учащихся одного класса получили оценку за контрольную работу. Сколько учащихся получили "двойку"?
- Дан двумерный массив А размером 3*3,заполненный с клавиатуры. Требуется умножить элементы этого массива на 4 ,если А(1,1)>0 или на 7, если А(1,1)<0.
- Дана строка символов,состоящая только из цифр. Опеределить,сколько раз среди них встречается цифра 5?

Читайте также

Дана строка русского текста до 60 символов.Слова разделены пробелами.Заменить встречающиеся в строке слова то на слово это.Напечатать исходную и

полученную строки.Напишите,пожалуйста,программу.Составить программу в паскале.

Дана стока состоящая из латинских букв,в которой слова разделены пробелами(одним или несколькими).Напечатать те строки,которые отличны от последнего слова

и удовлетворяют след. свойству:
- слово совпадает с начальным отрезком латинского алфавита ('a','ab','abc' и т.д.)

P.s. Только решить её надо не использую строки.Вместо них array of char...
Пример ввода:
writeln('Введите предложение, символ конца - точка');
i := 0;
repeat
inc(i);
read(a[i])
until (a[i] = '.')or(i = n);

Заранее огромное спасибо.

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

Как составить программу автоматического переноса слов? задается максимальная длина строки и предполагается, что слова разделяются пробелом. В этом

случае надо следить за текущей позицией в строке и при вводе очередного "слова" контролировать, чтобы его длина плюс текущая позиция не превысили длины строки. в QBasic



Вы находитесь на странице вопроса "Pascal: Дана строка. Слова разделены пробелами. Определить количество слов заданной длины", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.