Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Информатика. Помогите пожалуйста! Хоть один пункт :)

5-9 класс

Milanazubspb 28 дек. 2013 г., 14:47:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alinkaak
28 дек. 2013 г., 16:17:09 (10 лет назад)

var
x0,y0,x1,y1,r1,r2,k:real;
i,n:longint;
x,y,s:array[1..100] of real;
begin
x0:=0; y0:=0;
readln(r1); readln(r2);
k:=sqrt(sqr(x0-x1)+sqr(y1-y0));
if (k<r2) and (k>r1) then ('Yes') else writeln('No');
end.

var
x0,y0,x1,y1,r1,r2,k:real;
i,n,j:longint;
x,y,s:array[1..100] of real;
begin
x0:=0; y0:=0;
readln(r1); readln(r2); readln(n);
for i:=1 to n do readln(x[i],y[i]);
for i:=1 to n do
s[i]:=sqrt(sqr(x0-x[i])+sqr(y[i]-y0));
for i:=1 to n do
if (s[i]<r2) and (s[i]>r1) then inc(j);
writeln(j/n*100);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста

1)программа, которая выяснит символы от 91 до 96 (тип char)
2) соединение (написать программу по типу char)

На

столе лежат в четыре ряда фигуры:
треугольник, ромб, круг и квадрат. Цвета
этих фигур - зеленый, желтый, синий,
красный.
Фигура красного цвета
лежит между зеленой и синей, справа от
желтой фигуры лежит ромб, круг лежит
правее треугольника и ромба, причем
треугольник лежит не с краю и, наконец,
фигура синего цвета не лежит рядом с
фигурой желтого цвета. Какая фигура
какого цвета?

Исправить допущенные ошибки

Читайте также

Здравствуйте!Помогите пожалуйста с информатикой!

1.В ящике имеется 3 чёрных и 5 белых шаров.Какое наименьшее число шаров нужно взять из ящика ( не заглядывая в него), чтобы среди вытянутых шаров:.
1)Оказался хотя бы 1 чёрный
2)Оказался хотя бы 1 белый
3)Оказались хотя бы 2 чёрных
4)Окаазались хотя бы 2 белых
Если можно с решением,логическим рядом.
2. В одной книге было написано 100 следующих утерждений.
"В этой книге роно одно неверное утверждение"
"В этой книге ровно два неверных утверждения"
............................................................................................
"В этой книге ровно сто неверных утверждений.

Какое из этих утерждений верное?

Судя по моим мыслям,это явно не 3, тогда это получается правда, что противоречит смыслу предложения. Тогда какое получается? Я не знаю.Помогите пожалуйста. Напишите всё с решением пожалуйста.



Ах да,чуть не забыла. Если кто -то знает бесплатный решебник ( без всяких файлообменников) напишите пожалуйста.

Здравствуйте!Помогите пожалуйста с информатикой! 1.В ящике имеется 3 чёрных и 5 белых шаров.Какое наименьшее число шаров нужно взять из ящика ( не

заглядывая в него), чтобы среди вытянутых шаров:. 1)Оказался хотя бы 1 чёрный 2)Оказался хотя бы 1 белый 3)Оказались хотя бы 2 чёрных 4)Окаазались хотя бы 2 белых Если можно с решением,логическим рядом. 2. В одной книге было написано 100 следующих утерждений. "В этой книге роно одно неверное утверждение" "В этой книге ровно два неверных утверждения" ............................................................................................ "В этой книге ровно сто неверных утверждений. Какое из этих утерждений верное? Судя по моим мыслям,это явно не 3, тогда это получается правда, что противоречит смыслу предложения. Тогда какое получается? Я не знаю.Помогите пожалуйста. Напишите всё с решением пожалуйста. Ах да,чуть не забыла. Если кто -то знает бесплатный решебник ( без всяких файлообменников) напишите пожалуйста.

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

Всем информатикам сюда. Помогите пожалуйста,люди добрые...(

1)S=1+2+3...+10
for, while, repeat.

2)S=2+4+6+8...+20

for, while, repeat.
надо короче решить с помощью этих трех программ этот пример. что бы выходил этот ответ...помогите пожалуйста.

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.



Вы находитесь на странице вопроса "Информатика. Помогите пожалуйста! Хоть один пункт :)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.