Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Ребята, пожалуйста, помогите мне. Нужно сделать так, чтобы программы выделала имена, которые начинаются на большую букву и заканчиваются ласково на

10-11 класс

"чка" (т е Леночка и т д) Нажмите альт и F11
ПОЖАЛУЙСТА ПОМОГИТЕ

и объясните как вы это сделали
п с имена придумывала не я, у нас пошлый учитель

Rockstarider 10 июня 2014 г., 13:50:05 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Аннабелль
10 июня 2014 г., 16:44:18 (9 лет назад)

Там есть строка if, где проверяется условие. Вторая строка этого условия выглядит так:

And (Right(x, 3) = "чка") Or Right(x, 5) = "енька")

Тут программа проверяет, заканчивается ли слово на "чка" или "енька". Если да, то счётчик увеличивается на 1. Так вот, нам нужно чтоб этот счётчик увеличивался только для "чка". Для этого надо эту строку изменить так:

And (Right(x, 3) = "чка") 

- удалить то, что выделено жирным:

And (Right(x, 3) = "чка") Or Right(x, 5) = "енька")

 

Тогда программа будет считать только те ячейки, где имя оканчивается на "чка"

 

Во вложении - файл с исправленной программой.

 

Чтоб запустить программу, нажимаешь Alt+F8, -> в появившемся окошке "Macro" будет выбрано "ЭтаКнига.vasia" -> нажать кнопку Run -> в ячейке А11 появится результат "4" (то есть четыре имени подходят по условиям задачи, а сами имена будут написаны красным шрифтом

+ 0 -
Mitchell
03 июля 2016 г., 5:31:25 (7 лет назад)

I don't know who you wrote this for but you helped a broehtr out.

+ 0 -
Journey
04 июля 2016 г., 15:02:27 (7 лет назад)

Woot, I will cenrlitay put this to good use!

Ответить

Другие вопросы из категории

Паскаль

Вектор a = (x, y), вектор b = (u, v). Являются векторы параллельными или перпендикулярными?

Азбука Морзе позволяет кодировать символы для сообщегий по радиосвязи, задавая комбинацию точек и тире.Сколько различных символов (цифр,букв,знаков

пунктуации и т.д. ) можно закодировать используя код азбуки Морзе длиной пять или шесть сигналов ( точек и тире ) ? Помогите пожалуйста и с объяснениес =(

Читайте также

Помогите , мне нужны комментарии к этой программе.

Срочно!!
#include <stdlib.h>
#include <conio.h>
#include <stdio.h>
int schet(char *s);
int main() {
char vvod[100];
puts("Vvedite stroku:");
gets(vvod);
printf("%i \n", schet( vvod ));
system("pause");
return 0;
}

int schet(char *s)
{
int dlina, i, sum=0;
for(dlina=0; s[dlina]!='\0'; dlina++);
for(i=0; i if(s[i]>='0' && s[i]<='9')
{
sum=sum+s[i]-'0';
}
return sum;
}

Помогите пожалуйста, очень нужно!!

Как сделать так, чтобы в презентации(PowerPoint) нарисованная качеля качалась бесконечно?

Доброе утро. У меня и вам вопрос особенно к програмистам. Подскажите пожалуйста я создал свой сайт и выложил туда фильмы. Подскажите пожалуйста как

сделать так чтобы когда другие люди заходили на него и качали фильми, а мне шли за ето деньги.

Доброе утро. У меня и вам вопрос особенно к програмистам. Подскажите пожалуйста я создал свой сайт и выложил туда фильмы. Подскажите пожалуйста как

сделать так чтобы когда другие люди заходили на него и качали фильми, а мне шли за ето деньги.

пожалуйста помогите подскажите как делать такое задание в delphi

Нужно СЕГОДНЯ итак надо по номеру дня недели определить чем вы занимаетесь в свободное время.Можно написать любые занятия.
3 разные виды занятия.
Описать когда свободное время ,тоесть действия не определены.



Вы находитесь на странице вопроса "Ребята, пожалуйста, помогите мне. Нужно сделать так, чтобы программы выделала имена, которые начинаются на большую букву и заканчиваются ласково на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.