Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программы, которые определяют:

10-11 класс

- правда ли, что последняя цифра введенного числа кратна первой;
- правда ли, что сумма первой и последней цифр кратна 2;
- правда ли, что третья справа цифра равна 5 или 0;
- правда ли, что само число отрицательное;
Отработайте программы на Паскале с помощью компьютера

Because666 13 марта 2017 г., 17:04:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ksyusha345
13 марта 2017 г., 17:38:13 (7 лет назад)

1) На паскале: если число целое, то


var a : integer;
Label Transfer;
begin
readln(a);
Last := a mod 10;
N := 999
for counter = 1 To N Do
 if ((a div 10) < 10) and ((a div 10) > 0) 
    begin
    First := a div 10;
    Goto Transfer;
 else
    a := a div 10;
Transfer:
if (Last mod First = 0) then written('True')
                                    else written('False');
readln();
end.


Если что-то не понятно - в лс или в комменты сюда

Ответить

Другие вопросы из категории

Упростите логическое выражение или укажите его результат(при его однозначности).

Результат упрощения может содержать только операции инверсии,
конъюнкции и дизъюнкции.

A and B and not C ↔ (not A or B or C)

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

Написать программу Паскаль))) срочно!)))

Ввести с клавиатуры натуральное число.написать программу, которая определяет, кратна ли сумма его цифр 6.

Изначально, задача была такая: На вход программы подается натуральное число. Требуется написать программу, которая определяет составное или простое число

на входе и выводит сумму его цифр.

Я написал первую часть программы (без вывода суммы цифр) :

program sg3;

uses crt;

var i,a,k: integer;

begin

clrscr;

write('Введите число: ');

readln(a);

k:=0;

for i:=2 to a div 2 do

if a mod i =0 then k:=k+1;

if k=0 then write('Простое')

else writeln('Составное');

readln;

end.

Допишите пожалуйста код, который бы выводил сумму цифр,Паскаль

Требовалось написать программу, которая вводит с кла­виатуры

координаты точки на плоскости (х,у — действи­тельные числа) и определяет
принадлежность точки за­штрихованной области, включая ее границы. Програм­мист
торопился и написал программу неправильно.



Вы находитесь на странице вопроса "Написать программы, которые определяют:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.