Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить программу нахождения корней квадратного уранения(описать)срочно!

5-9 класс

AMc 23 июня 2014 г., 23:00:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
антонинатоня10
24 июня 2014 г., 0:18:49 (9 лет назад)

#include <iostream> 
#include <cmath>
using namespace std;

int main()
{
  float a,b,c;
  do
  {
      cout <<"A = ";
      cin >>a;
  }
  while (a==0); 
  cout <<"B = ";
  cin >>b;
  cout <<"C = ";
  cin >>c;
  if (b==0 && c==0)
    cout <<"KOREN: 0" <<endl;
  else
  {
     if (b!=0 && c!=0)
     {
       float d=b*b-4*a*c;
       if (d<0)
         cout <<"NET KORNEY" <<endl;
       else if (d==0)
         cout <<"KOREN: " <<-b/(2*a) <<endl;
       else 
       {
         float x1 = (-b+sqrt(d))/(2*a),x2 = (-b-sqrt(d))/(2*a);
         cout <<"KORNI: " <<x1 <<" " <<x2 <<endl;
       }
     }
     else if (b!=0 && c==0)
            {
              float x1 = 0,x2=-b/a;
              cout <<"KORNI: " <<x1 <<" " <<x2 <<endl;
            }
            else
            {
               if ((c>0 && a>0) || (c<0 && a<0))
               cout <<"NET KORNEY" <<endl;
             else
              {
                float x1=sqrt(-c/a),x2=-x1;
                cout <<"KORNI: " <<x1 <<" " <<endl;
              }
            }
  }
  return 0;
}

+ 0 -
Незнайка2034
24 июня 2014 г., 3:10:08 (9 лет назад)

паскаль?

Ответить

Другие вопросы из категории

с помощью толковых словарей перечислите существенные признаки составляющие содержание понятий

агроном,брейк,видеоклип,дюйм,жалюзи,камбала,мультипликация,пастила и универсальный.

ПОМОГИТЕ ПОЖ! ОЧЕНЬ НАДО!

как перевести число с восьмеричной с.с. в десятичную и посторить изображение, если даны координаты

Помогите ребят :)

Нужно решить по информатики уравнения .
X*(a+b)= c

Читайте также

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n



Вы находитесь на странице вопроса "Составить программу нахождения корней квадратного уранения(описать)срочно!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.