Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Одно число в 2 раза больше другого, а их сумма равна s. Найти эти числа. Паскаль. Пожалуйста срочно надо.

10-11 класс

Asve56 20 мая 2014 г., 0:26:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Minius1024
20 мая 2014 г., 1:24:25 (9 лет назад)

var
    s, i : Integer;
begin
    Write('Введите сумму двух чисел: ');
    ReadLn(s);

    if s mod 3 = 0 then
    begin
        i := s div 3;
        Writeln('a = ', i);
        Writeln('b = ', i*2);
    end
    else
        Writeln('Таких чисел нет.');

    Readln;

+ 0 -
Ириска332255
20 мая 2014 г., 2:53:15 (9 лет назад)

Это все данные?

+ 0 -
Уленочка
20 мая 2014 г., 4:37:38 (9 лет назад)

да

Ответить

Другие вопросы из категории

Паскаль

найти количество и сумму двухзначных чисел, кратных 3 и 5 одновременно

Какой из микропроцессоров является представителем архитектуры RISC?

(укажите несколько правильных ответов)


1) AMD K7

2) i80386

3) ALPHA 21264

4) TMS320C620

5) mPD 2864

перевести из одной системы в другую:




2-10

с решением пожалуйста!!!

Читайте также

Три десятичных числа(100,102,91) перевести в восьмеричную систему вычислить их сумму и перевести в десятичную систему вычислить их сумму и перевести в

дестяричную
Три двоичных числа перевести в 16-ую систему,вычислить их сумму и перевести в десятичную систему
Три двоичных числа,перевести в 8-ую систему,а затем в 16-ую.

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Ребят помогите программу дописать по vba: в общем нужно сделать матрицу с рандомными числами, найти наименьшее число в ней, и сделать другую матрицу на

порядок меньше, с вычеркнутым столбцом и строкой на пересечении которых находится наименьшее число из первой матрицы. Я нашел наименьшее число, а как дольше делать понять не могу.
Вот начало самой программы:
Sub laba9()
Dim N As Integer, a() As Integer, i As Byte, j As Byte, min As Integer, l1 As Integer, l2 As Integer
N = Val(InputBox("Введите размерность массива"))
ReDim a(N, N)
Sheets("Лист1").Select
Sheets("Лист1").Range("A1:AAA100").Clear
For i = 1 To N
For j = 1 To N
a(i, j) = Rnd * 100
Cells(i, j) = a(i, j)
Next j
Next i
min = a(1, 1)
l1 = 1
l2 = 2
For i = 1 To N
For j = 1 To N
If a(i, j) < min Then
min = a(i, j)
l1 = i
l2 = j
End If
Next j
Next i
End sub



Вы находитесь на странице вопроса "Одно число в 2 раза больше другого, а их сумма равна s. Найти эти числа. Паскаль. Пожалуйста срочно надо.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.