Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль

10-11 класс

Дан массив размера n и целые числа К и 1 (1? K? 1?n) . Найти сумму элементов массива с номерами от К до 1 включительно.

OK1234 15 июля 2013 г., 20:22:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
хомячочек2810
15 июля 2013 г., 22:54:07 (10 лет назад)

const  n = 10;
var  a :array [1..n] of integer;  i, k, sum :integer;
begin
  for i:= 1 to n do    readln(a[i]);  readln(k);  sum:= 0;  for i:= 1 to k do    sum:= sum + a[i];
end.

+ 0 -
Olesya190798
15 июля 2013 г., 23:25:13 (10 лет назад)

Uses crt;
Var m:array[1..1000] integer;
i,n,k,sm:integer;
Begin
Clrscr;
Writeln('Введите размер массива '); readln(n);
Repeat
Writeln('Введите K < ',n) readln(k);
Until k<=n;
For i:=1 to n do
M[i]:=random(60)+1;

Sm:=0;
For i:=k downto 1 do
Sm:=sm+m[i];

Writeln('Сумма элементов массива с нумерацией от 1 до ',k,' равно ',sm);
Readkey;
End.

Ответить

Другие вопросы из категории

помогите решить пліз хотяби несколько

]Варіант-1
Дана послідовність слів. Визначити кількість букв “А” і “Б” в ній. Якщо таких букв немає, то вивести повідомлення.

Варіант-2
Скласти програму, яка підраховує число тих слів у реченні із И букв, в яких на другій позиції знаходиться задана буква. Слова розділенні пропусками. Якщо таких слів немає, то видається повідомлення .

Варіант-3
Скласти програму, яка із заданого слова вилучає всі букви “А”.

Варіант-4
Скласти програму, яка виводить на екран всі символи.

Варіант-5
Скласти програму, яка визначає скільки цифр у заданому числі і знаходить їх добуток.

Варіант-6
Скласти програму, яка підраховує кількість букв у введеному реченні. Словом м/б розділенні пропусками, або комами.

Варіант-7
Написати програму, яка перевіряє чи стоїть перед “що” кома.

Варіант-8
Написати програму, яка перевіряє чи поставили в кінці речення, що вводиться крапка.

Варіант-9
Скласти програма, яка виводить слово ззаду на перед.

Варіант-10
Дана послідовність слів. Перевірити чи є в ній задане слово.

Варіант-11
Задати речення. Програма повинна виводити на екран всі символи, що зустрічаються до першого знака “-”. Якщо його немає, то виводиться повідомлення.

Варіант-12
Вивести слово задом наперед.

Варіант-13
У заданому реченні знайти найдовше (найменше) слово.

Варіант-14
Скласти програму, яка із слова “інтеграл” утворює слово “гантелі”, “тигр”.



Варіант-15
Знайти найменше із слів, що записані в реченні.

Варіант-16
Написати програму, яка по назві дня неділі визначає номер цього дня 1...,2,...,7.

Варіант-17
Дана послідовність слів підрахувати скільки слів закінчуються на “А”.

Варіант-18
Скласти програму, яка підраховує скільки раз в послідовність слів зустрічається буквосполучення “сок”.

Варіант-19
Написати програму, яка виводить на екран коди всіх букв.

Варіант-20
Скласти програму, яка перевіряє чи поставили вкінці речення “крапку”.

Варіант-21
Програма підраховує число тих слів в, яких на другій позиції стоїть буква “А”.

Варіант-22
Скласти програму, яка виводить на екран всі символи після знаків “-“.

Варіант-23
Написати програму, яка визначає, чи являється введене слово “перевертишем” (напр. “ПОТОП”, “КАЗАК”).

Варіант-25
Скласти програму, яка вилучає із заданого слова всі букви “А”.

Решить на C#, используя циклы. Составить программу для вычисления и вывода n первых чисел Фибоначчи. Числа Фибоначчи получаются с помощь

ю следующих рекуррентных соотношений f_{1}=f_{2}=1, f_{n}=f_{n-1}+f_{n-2}, n\geq3, где f_{n} - целое. Отследить корретность ввода исходных данных.

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.