Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите пожалуйста сделать=)))

10-11 класс

а) Написать программу, определяющую среднее арифметическое всех чисел от 0 до заданного пользователем.

б)Написать программу, определяющую количество четных чисел от 0 до заданного пользователем числа.

Spaun1234 28 мая 2014 г., 5:12:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Батырлан
28 мая 2014 г., 6:52:12 (9 лет назад)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int number, counter = 0;
   float average = 0;

   cout << "Enter the number: ";
   cin >> number;

   //1)
   for(int i = 0; i <= number; i++)
   {
      average += i;
   }
   average /= (number + 1);

   //2)
   for(int i = 0; i <= number; i++)
   {
      if(i % 2 == 0) //Если чётное
      {
         counter++;
      }
   }

   cout << "Average = " << average << endl;
   cout << "The amount of even elements: " << counter << endl;

   return 0;
}

Ответить

Другие вопросы из категории

Написать Программу в паскале которая посчитала бы 5^123 (это цикл как бы должен быть)

http://primat.org/index/0-128 вот сайт что бы написать программу.

16^х=32 помогите срочно пожалуйста
1)определить значение целочисленных переменных а и b после выполнения фрагмента алгоритма:

a:=40
b:=6
a:=div(a,b)
b:=a*b
a:=div(b,a)

а)а=3,b=18. б)а=6,b=18. в)a=6,b=36. г)a=6,b=12

2)используя таблицу расшифруйте слово и запишите его в ответ(смотреть фото)

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Люди добрые помогите пожалуйста(сделайте подробно)

1.Какое количество информации получит игрок, которому из колоды в 32 карты
достают короля пик? А если то же, но из колоды в 36 карт?
2. В рулетке общее количество лунок 128. Какое количество информации мы получаем, увидев, что шарик остановился в 25 черное?
3.Сколько страниц в брошюре, если сообщение о том, что случайно открылась 17 страница содержит 6 бит информации?
4. Сколько нужно задать вопросов, чтобы угадать натуральное число не более 100?



Вы находитесь на странице вопроса "помогите пожалуйста сделать=)))", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.