Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 25. program B08; var x, a,b: interger;

10-11 класс

begin

readln(x);

a:=0; b:=0;

while x>0 do

begin

a:=a+1;

if (x mod 2)<>then

b:= b+(x mod 10);

x:=x div 10;

end;

writeln(a); write(b ;

end.

Romukdoodlik 01 февр. 2015 г., 3:02:35 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tulinov02
01 февр. 2015 г., 4:10:10 (9 лет назад)

Ответ: 997

Программу правильно допиши:

var x, a,b: integer;
begin
   readln(x);
   a:=0; b:=0;
   while x>0 do
   begin
     a:=a+1;     
     if (x mod 2) <> b then
        b:= b+(x mod 10);
    x:=x div 10;
end;
    writeln(a); write(b) ;
end.

(исправленный вид)

+ 0 -
AkerkeA
01 февр. 2015 г., 6:57:34 (9 лет назад)

997

+ 0 -
Катюшка377
01 февр. 2015 г., 9:18:25 (9 лет назад)

спасибо)

Ответить

Другие вопросы из категории

Читайте также

Решите, пожалуйста!!!

Ниже
записана программа. Получив на вход число x, эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а
потом 28.

информатика

Ниже на четырёх языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 13, а потом 5.

Получив на вход число х, этот алгоритм печатает два числа К и R. Укажите наименьшее из таких чисел х, при вводе которых алгоритм печатает сначала 4, а

потом 3.
var x, i, K, R, y: integer;
begin
readln(x);
K := 0; R := 9;
y := x mod 10;
while x > 0 do begin
K := K + 1;
if R > x mod 10 then
R := x mod 10;
x := x div 10
end;
R := y - R;
writeln(K); writeln(R)
end.



Вы находитесь на странице вопроса "укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 25. program B08; var x, a,b: interger;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.