Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составьте программу, которая формулирует массив из 20 целых чисел и находит индексы нулевых элементов.

5-9 класс

Jambolat 26 марта 2017 г., 9:40:01 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastjuwechka123
26 марта 2017 г., 12:05:13 (7 лет назад)

const n=20;
var a:array [1..n] of integer;
i:byte;
begin
for i:=1 to n do
readln(a[i]);
for i:=1 to n do
if a[i]=0 then write(i,'  ');
readln;
end.

Ответить

Другие вопросы из категории

ваш приятель Дима живёт в доме, в некотором 8 квартир. Вы не знаете, в какой именно квартире он живёт. Подойдя к дому, вы встретили девочку, которая знает

номер квартиры Димы, но после каждого вопроса лишь кривая головой(<да>) или мотает (<нет>). Какое наименьшее количество вопросов необходимо задать девочке, чтобы узнать номер квартиры Димы?

Число 1357 в римской системе счисления запишется как:

Выберите один ответ:
MCCCLVII
01357
MXXXLIIIX
MCCCVIIIX
I III V VII
Двоичное число 1101,12 при переводе в десятичную систему счисления в будет равняться:
Выберите один ответ:
13,5
17,25
11,05
15
15,15
Двоично-десятичное число 101010100 при переводе в десятичную систему счисления будет равняться числу:
Выберите один ответ:
17710
12110
20210
20510
15410

Читайте также

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.



Вы находитесь на странице вопроса "Составьте программу, которая формулирует массив из 20 целых чисел и находит индексы нулевых элементов.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.