Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Дан

10-11 класс

массив целых чисел, размерность которого N.
Подсчитать, сколько в нем разных элементов.

КандидатПаук 01 июля 2013 г., 4:00:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
05веруня
01 июля 2013 г., 4:45:48 (10 лет назад)

Раз массив уже дан, то не стала писать программу ввода элементов, а так само вычисление кол-ва элементов вот: 
Dim A(N)
T=0
For i= 1 to N-1
k=0
For j= i+1 to N
If A(i) = A(j) then k=k+1
Next j
if k≥1 then T=T+1
Next i
S = N - T
Print S

Вроде так

+ 0 -
200446
01 июля 2013 г., 6:54:33 (10 лет назад)

надо написать в паскаль

Ответить

Другие вопросы из категории

Помогите пожалуйста! Желательно с объяснениями!

Какое количество информации получит второй игрок при игре в крестики-нолики на поле
размером 8x8 клеток, после первого хода первого игрока, играющего крестиками?

Помогите описать алгоритм!!!

uses crt;


var s, sn, sg: string;


i: integer;


begin


write('s=');


readln(s); sn:='';


for i:=1 to length(s) do

Для кодирования

букв Е,П, Н, Ч, Ь используются двоичные
коды чисел 0, 1, 2, 3 и 4 соответственно (с
сохранением одного незначащего нуля
в случае одноразрядного представления).
Если таким способом закодировать
последовательность символов ПЕЧЕНЬЕ
и записать результат в восьмеричном
коде, то получится:


1) 1030240 2) 12017 3) 2141351 4) 23120

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

Читайте также

Данные, объемом 16 Мбайт, поступают на компьютер по линии со скоростью передачи данных 32 Мбит/с. После получения 4 Мбайт компьютер начинает одновременно

передавать эти данные по другой линии связи со скоростью 4 Мбит/с. Сколько секунд пройдет от начала приема данных по высокоскоростному каналу до полной передачи их по низкоскоростному каналу?

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

C++Написать программу вычисления объема параллелепипеда. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные

пользователем, выделены полужирным шрифтом).

Вычисление объема параллелепипеда.

Введите исходные данные:

Длинна (см): 9

Ширина (см): 7.5

Высота (см): 5



Вы находитесь на странице вопроса "Дан", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.