Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

написать программу,позволяющая вычислять множество значений среди положит. элементов массива

10-11 класс

Zaripusha 19 февр. 2014 г., 18:17:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Suminagalinag
19 февр. 2014 г., 19:54:35 (10 лет назад)

var
   i:integer;
  mas:array[1..10] of integer;
begin
writeln('Исходный массив: ');
for i:=1 to 10 do
  begin
  mas[i]:=random(-10,10);
  write(mas[i],' ')
  end;
writeln;
writeln('Положительные элементы: ');
for i:=1 to 10 do
  if mas[i]>0 then write(mas[i],' ')
end.

+ 0 -
Zyongvika51
19 февр. 2014 г., 22:19:48 (10 лет назад)

Условие точно написала? Что-то я не понимаю, что с положит. эл-ми делать?))

+ 0 -
Timush13
20 февр. 2014 г., 1:09:34 (10 лет назад)

найти

Ответить

Другие вопросы из категории

По краю очень большого круглого стола с равными интервалами разложены небольшие конверты, в каждом из которых лежат деньги. Известны суммы, лежащие в

каждом конверте. Опишите алгоритм, позволяющий провести прямую через центр стола, разделяющую конверты на два множества с одинаковой суммой денег. Прямая не должна проходить по конвертам. Если такой прямой нет – сообщите об этом.

Читайте также

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

1)написать программу, которая вычисляет произведение сумм всех соседних пар целых чисел из диапазона от 12 до 36 и выводит значения тех сумм, которые

меньше 52.

2)В результате работы некоторой подпрограммы вычислены значения четырех переменных a, b, c, d. Написать на предложенном в пункте а) языке программирования программу, после работы которой в случае, если сумма положительных значений (среди a, b, c, d) больше 20, значение g равно наибольшему из a, b, c, а в остальных случаях значение g равно значению d. (В программе можно использовать новые переменные.)

дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно. Опишите на естественном языке или на

одном из языков программирования алгоритм, позволяющий найти и вывести максимальное значение среди трехзначных элементов массива, оканчивающихся на 0

PASCAL

Пользователь вводит одномерный массив(1..15).Вывести его в обратном порядке и посчитать произведение элементов.

Посчитать произведение элементов,стоящих на главной диагонали массива 4:4,введенного пользователем.Сам массив выписать

Дан целочисленный массив из 20 элементов.Элементы массива могут принимать целые значения от 0 до 10000 включительно.Опишите их алгоритм,позволяющий найти и вывести макс. значение среди трехзначащих элементов массива,не делящихся на 9.Если в исходном массиве нет элементов,которые явл. трехзнач. числов,при этом не кратно 9,то выведет сообщение не найдено.



Вы находитесь на странице вопроса "написать программу,позволяющая вычислять множество значений среди положит. элементов массива", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.