Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

составить программу на языке паскаль: введите с клавиатуры значение сторон трапеции и найдите её площадь.

10-11 класс

Shaydulina 27 июня 2014 г., 12:33:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bayrambayramov1
27 июня 2014 г., 14:27:45 (9 лет назад)

program aliona;
var h,a,b,c,d,p,s:integer;
begin
writeln('wedite a,b,c,d');
readln(a,b,c,d);
p:=(a+b)/2;
h:=sqrt(sqr((b-a)/2)+sqr(c));
s:=p*h;
writeln ('s=',s);
readln;
end.

Ответить

Другие вопросы из категории

Си++

Дана матрица размером Nстрок и Mстолбцов. Найти количество положительных чисел в столбце.

Опишите

способы кодирования информации, снабдив их соответствующими примерами

составить программу для машины Тьюринга:

1)которая добавляет к слову из единиц две единицы слева;
2)которая сдвигает слово из единиц на две единицы вправо;
3)которая переводит слово муха в слово слон, а остальные слова удаляет.

Один стакан лимонада содержит 15 калорий, 1 кусок торта - 150 калорий, 1 драже "Тик-Так"- 2 калории. Во время праздничного обеда Буратино выпил 5 стакан

ов лимонада, съел 20 драже "Тик-Так" и 4 куска торта. Мальвина съела 2 драже "Тик-Так", 1 кусок торта и выпила 1 стакан лимонада. Пьеро выпил 2 стакана лимонада и съел 2 куска торта. Дуремар съел 3 куска торта и выпил 2 стакана лимонада.

Построить электронную таблицу, из которой будет видно: сколько всего стаканов лимонада было выпито, кусков торта и драже "Тик-Так" съедено; сколько калорий употребил каждый участник праздничного обеда; сколько калорий содержалось во всем выпитом лимонаде, всех съеденных кусках торта и драже "Тик-Так".

Читайте также

Составить программу на языке паскаль

задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать

значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)

помагите пжл, составить программу на языке ПАСКАЛЬ СОСТАВИТЬ ПРОГРАММУ СОКРАЩЕНИЯ ОДНОМЕРНОГО ЧИСЛОВОГО МАССИВА ПУТЕМ УДАЛЕНИЯ ( ВСЕХ ЭЛЕМЕНТОВ С НУЛЕВЫ

МИ ЗНАЧЕНИЯМИ . ДОПОЛНИТЕЛЬНЫЙ МАССИВ ИСПОЛЬЗОВАТЬ НЕ РАЗРЕШАЕТСЯ ) .........ЕСЛИ МОЖЕТИ ПОЯСНИТЕ СЛОВАМИ ЧТО ДЕЛАЕТ ПРОГРАММА



Вы находитесь на странице вопроса "составить программу на языке паскаль: введите с клавиатуры значение сторон трапеции и найдите её площадь.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.