Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Строки (цепочки символов латинских букв) создаются по следующему правилу.

5-9 класс

Первая строка состоит из одного символа – латинской буквы «А». Каждая из последующих цепочек создаётся такими действиями: в очередную строку сначала записывается буква, чей порядковый номер в алфавите соответствует номеру строки, к ней слева дважды подряд приписывается предыдущая строка.
Вот первые 4 строки, созданные по этому правилу:
(1) A
(2) AAB
(3) AABAABC
(4) AABAABCAABAABCD

Запишите шесть символов подряд, стоящих в восьмой строке с 10-го по 105-е место (считая слева направо).

Densova2002 20 дек. 2014 г., 9:22:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valery4
20 дек. 2014 г., 10:37:06 (9 лет назад)

var
  s: string;
  i,start,j: integer;

begin
  start:= ord('A');
  s:= 'A';
  for i:= 2 to 8 do begin
    s:= s+s+char(start+1);
    inc(start);
    if i=8 then for j:= 10 to 15 do write(s[j])
  end
end.

Ответить

Другие вопросы из категории

Составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае:

а)точка с координатами (х,у) принадлежит части плоскости, лежащей между прямыми
х=m,х=n (m<n);
б)данная тройка натуральных чисел a,b,c является тройкой Пифагора, т.е. c^2=a^2+b^2;
в)данные числа х,у являются координатами точки, лежащей в первой координатной четверти;

Помогите решить хотя бы несколько вопросов !

1.Укажите правильный адрес ячейки:
А)AI2C Б)B1256 В) 123C Г)B1A
2.В электронных таблицах выделена группа ячеек А1:В3. Сколько ячеек входит в этот диапазон?
А)6 Б) 5 В) 4 Г)3
3.Результатом вычислений в ячейке С1 будет:
(таблица вопроса 3)
4. В ЭТ нельзя удалить:
а.столбец б. строку в. имя ячейки г. содержимое ячейки
5. Основным элементом ЭТ является:
а. ячейка б. строка в. столбец г.таблица
6.Укажите неправильную формулу
а. A2+B4 Б.=A1/C453 В =C245*M67 Г=O89-K89
7. При перемещении в ЭТ абсолютные ссылки
а. не изменяются
б. преобразуются вне зависимости от нового положения формулы
в. преобразуются в зависимости от нового положения формулы
г. преобразуются в зависимости от длины формулы
8. Диапазон это
а. все ячейки одной строки
б. совокупность клеток,образующих в таблице область прямоугольной формы
в.все ячейки одного столбца
г. множество допустимых значений







Читайте также

Строки (цепочки символов латинских букв) создаются по следующему правилу.

Первая строка состоит из одного символа – латинской буквы «А». Каждая из последующих це-почек создаётся такими действиями: в очередную строку сначала записывается буква, чей поряд-ковый номер в алфавите соответствует номеру строки, к ней слева дважды подряд приписывает-ся предыдущая строка.
Вот первые 4 строки, созданные по этому правилу:
(1) A
(2) AAB
(3) AABAABC
(4) AABAABCAABAABCD
Выпишите буквы, которые могут стоять в 256 позиции в девятой и всех последующих стро-ках. Ответ обосновать. Латинский алфавит для справки: ABCDEFGHIJKLMNOPQRSTUVWXYZ

Строки (цепочки символов латинских букв) создаются по следующему правилу.

Первая строка состоит из одного символа – латинской буквы «А». Каждая из последующих це-почек создаётся такими действиями: в очередную строку сначала записывается буква, чей поряд-ковый номер в алфавите соответствует номеру строки, к ней слева дважды подряд приписывает-ся предыдущая строка.
Вот первые 4 строки, созданные по этому правилу:
(1) A
(2) AAB
(3) AABAABC
(4) AABAABCAABAABCD
Выпишите буквы, которые могут стоять в 256 позиции в девятой и всех последующих стро-ках. Ответ обосновать. Латинский алфавит для справки: ABCDEFGHIJKLMNOPQRSTUVWXYZ

пожалуйста помогите!

Строки (цепочки латинских букв) создаются по следующему правилу. Первая строка состоит из одного символа - латинской буквы "А". Каждая из последующих

цепочек создается такими действиями: в очередную строку сначала записывается буква, чей порядковый номер в алфавите соответствует номеру строки (на i-м шаге пишется "i"-я буква алфавита), к ней слева и справа приписывается предыдущая строка. Вот первые 3 строки, созданные по этому правилу:
(1) A
(2) ABA
(3) ABACABA
Запишите шесть символов подряд, стоящие в седьмой строке со 122-го по 127-е место (считая слева направо).

Цепочка из четырех бусин, помеченных латинскими буквами, формируется по следующему правилу:

– на третьем месте цепочки стоит одна из бусин A, E;
– на втором месте – одна из бусин H, E, D, которой нет на третьем месте;
– в начале стоит одна из бусин H, A, C, которой нет на втором месте;
– в конце – одна из бусин H, E, D, не стоящая на первом месте.
Определите, сколько из перечисленных цепочек созданы по этому правилу?
HDEE HHAE HEAE AHAH AEAD AEED CAEH EHAD CDEAВ
с решением, пожалуйста

Цепочки символов (строки) создаются из букв латинского алфавита по следующему правилу: Первая строка состоит из двух символов – это буквы

«AB».

Каждая из последующих цепочек создается такими действиями: в начало записывается буква, следующая по алфавиту, далее записывается предыдущая строка и она же в обратном порядке символов (справа налево).

Вот первые 4 строки, созданные по этому правилу:

(1) AB

(2) BABBA

(3) CBABBAABBAB

(4) DCBABBAABBABBABBAABBABC

Сколько раз буква А встречается в 8-ой строке?



Вы находитесь на странице вопроса "Строки (цепочки символов латинских букв) создаются по следующему правилу.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.