Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

что не так в моей задаче по Паскалю?

10-11 класс

Program A;
Var z,b,i:integer;
begin randomize;
z:=randon(16);
b:=randon(16);
i:=randon(16);
writeln('z=',z,'b=',b,'i=',i);
if (z>b) and (b>i) then writeln('z=',z,'b=',b,'i=',i);
if (z>i) and (i>b) then writeln('z=',z,'i=',i,'b=',b);
if (zz) and (bi) and (i>z) then writeln('b=',b,'i=',i,'z=',z);
if (bi) then writeln('z=',z,'i=',i,'b=',b);
readln(z,b,i);
end.

дьявол765353563 06 дек. 2016 г., 19:16:43 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chinana
06 дек. 2016 г., 22:04:50 (7 лет назад)

if (zz) and (bi) and (i>z) then writeln('b=',b,'i=',i,'z=',z);
if (bi) then writeln('z=',z,'i=',i,'b=',b);

в этих строках в скобках нужно писать условие, а там необявленные переменные zz,  bi

а в конце зачем вводишь переменные z, b, i ?  там же конец программы уже.
просто напиши   readln;  или  readkey;  - пауза

+ 0 -
Alyonaserqeeva
06 дек. 2016 г., 23:45:00 (7 лет назад)

И неизвестные имена zz,bi

+ 0 -
Rtyui2528
07 дек. 2016 г., 0:48:13 (7 лет назад)

Это их произведение, что-ли надо было написать?

+ 0 -
Prostss
07 дек. 2016 г., 2:30:08 (7 лет назад)

у пишет ошибку в последних 4х строках

+ 0 -
Alenaaa371
07 дек. 2016 г., 4:37:02 (7 лет назад)

Ну он zz не понимает. Нет такой переменной ведь!

+ 0 -
0707Margo0707
07 дек. 2016 г., 6:24:56 (7 лет назад)

Условие задачи привела бы

Ответить

Другие вопросы из категории

Задача

D Три числа

Читайте также

Здравствуйте) помогите составить задачи по паскалю)

задачи на такую тему: Составление, ввод, трансляция и
исполнение программ, реализующих
циклические алгоритмы и типовые
операции с одномерными массивами

Олимпиадные задачи требуют ввод-вывод данных с использованием внешних файлов как это сделать? ИНФОРМАТИКА конспекты уроков 9-11 классы Чернов

А.А. с198

program pr;

uses crt;

var f:file of integer;

n:integer;

a:string;

begin

clrscr;

a:='c:\f1.txt';

assign(f,a);

rewrite(f);

writeln('n: ');

readln(n);

write(f,n);

close (f);

readln;

end.

после выполнения программы в файле f1.txt вместо значения n=5 появилось -256

что не так ?

Помогите решить задачи по паскалю:

1. модифицируйте предыдущий пример, так чтобы программа определяла максимальный и минимальный элемент массива
2. Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (вещественная величина типа real)
Начало:
var a: array[1..10] of integer;
i: integer;
begin
а как дальше?

Предыдущий пример:
var a: array[1..10] of integer;
i: integer;
begin
randomize;
for i:=1 to 10 do
begina[i]:=random(40)-20;
end;
for i:=1write(a[i]:4);
end.



Вы находитесь на странице вопроса "что не так в моей задаче по Паскалю?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.