Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Данна матрица 4Х5 построить одномерный массив b состоящий из наименьших значений элементов строк.

10-11 класс

Gobnik 27 нояб. 2013 г., 1:06:02 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hcfyhd
27 нояб. 2013 г., 3:25:49 (10 лет назад)

Пример на VBA Excel
Программу можно посмотреть нажав Alt+F11

+ 0 -
Bulatzakirov2
27 нояб. 2013 г., 6:13:14 (10 лет назад)

uses crt;
var m:array[1..4,1..5]  of integer;
    b:array[1..4] of integer;
    min,i,j:integer;
begin
clrscr;
for i:=1 to 4 do
begin
for j:=1 to 5 do
begin
m[i,j]:=random(35)-30;
end;
end;
for i:=1 to 4 do
begin
for j:=1 to 5 do
write(m[i,j]:3,'  ' );
writeln;
end;
 min:=m[1,1];
for i:=1 to 4 do
begin
for j:=1 to 5 do
begin
if min>m[i,j] then min:=m[i,j];
end;
b[i]:=min;
min:=m[i+1,1];
end;
for i:=1 to 4 do
writeln(i,') ',b[i]);
readkey;
end.

+ 0 -
Ольга5412
27 нояб. 2013 г., 8:18:33 (10 лет назад)

а вам конкретно в какой среде это нужно воплотить

+ 0 -
Leraershova03
27 нояб. 2013 г., 11:09:43 (10 лет назад)

Turbo Pascal

Ответить

Другие вопросы из категории

Задача F Четный палиндром

Подстрокой строки называется любая непустая последовательность символов в строке. Палиндромом называется строка, которая читается одинаково слева и справа.
У Азизхана есть строка S. Его интересует сколько есть подстрок четной длины у строки S, которые являются палиндромами. Одинаковые подстроки начинающие с разных позиций считаются разными.
Формат входных данных
Единственная строка входного файла содержит одну строку S состоящее из строчных букв английского алфавита (1 <= длина S <= 100000).
Формат выходных данных
Выведите ответ к задаче.

системы счисления

упр 50, пункт 3)
с объяснением, пожалуйста

Читайте также

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему. Дан одномерный массив А состоящий из 10

элементов.Вывести на экран исходную таблицу и резултат программы.

Найти произведения элементов массива А. удовлетворяющих условию:

c<=A[i]<=d.

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему.ПО ПАСКАЛЬ.!!

Дан одномерный массив А состоящий из 10 элементов.Вывести на экран исходную таблицу и резултат программы.
Найти произведения элементов массива А. удовлетворяющих условию:
c<=A[i]<=d.

44 балла

Помогите решить две задачки (Паскаль)

Задание 1
Создать одномерный массив А, состоящий из сумм столбцов матрицы В(8,5). Определить в созданном массиве минимальный элемент и его местоположение, а также произведение всех элементов.

Задание 2
В двумерном массиве G(7,5) поменять минимальный элемент 2 строки и максимальный элемент 5 столбца. В полученной матрице вычислить значение произведения элементов главной диагонали. Заменить значение третьего элемента в первой строке на значение произведения.



Вы находитесь на странице вопроса "Данна матрица 4Х5 построить одномерный массив b состоящий из наименьших значений элементов строк.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.