Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

паскаль 1)

10-11 класс

Составить программу, которая определяет произведение цифр четырехзначного числа, введенного пользователем.
2)
Составить программу, которая по формулам для арифметической прогрессии находит сумму n первых элементов прогрессии и значения трех элементов с номерами (n–1), n и (n+1). Число n, первый элемент и разность прогрессии вводятся пользователем. Вывести значения элементов в форме таблицы, где первая строка – номер, а вторая – значение.

0502883896a 05 сент. 2013 г., 10:48:33 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
5673455
05 сент. 2013 г., 13:27:53 (10 лет назад)

var n,s,p,a: integer;  {n - число}

 

Begin

///// Считываешь инфу

s:=s+(n mod 10);  // к сумме прибавляем последнюю цифру

p:=p*(n mod 10);  // на произведение умножаем последнюю цифру

a:=n div 10;  //  берем из 3х знач числа 2х значное. Например было 123 стало 12

s:=s+(a mod 10); // берем последнюю цифру 2х значного числа(2) к сумме

p:=p*(a mod 10); // берем последнюю цифру 2х значного числа(2) к произведению

a:=n div 10;  // Берем 1-значное число из 2х значного(1)

s:=s+a; //  Прибавляем сотый разряд к сумме

p:=p*a; // к произведению

//// записываешь инфу

end.

 

p - роизведение

s - суммa

 

 

как ты понял я нашел еще и сумму. Просто я скопировал свое решение к другом заданию. Думаю так даже будет понятнее.

 

насчет второго задания. поясните мне точные формулы и порядок решения в личном сообщении, т.к. я плохо Вас понял. Я уверен, что смогу помочь, предоставте мне полную информацию. Это связано с моими не обширными знаниями в математики. Но я могу свободно реализовать формулы в программе.

+ 0 -
Лtyjxrf
05 сент. 2013 г., 14:57:33 (10 лет назад)

1)

var a: 1000..9999;

      a1, a2, a3, a4: 1..9;//Цифры числа

begin

  writeln('Введите четырехзначное число');

  readln(a);

  a4:= a mod 10; //Последняя цифра

  a3:= (a mod 100) div 10;

  a2:= (a mod 1000) div 100; 

  a1:=a div 1000;//Первая слева цифра

  writeln('Произведение цифр числа: ',a1 * a2 * a3 * a4);

end.

2)

var

  n: integer;

  d, s: real;

  a1: real;

begin

  writeln('Введите число n');

  readln(n);

  writeln('Введите разность прогрессии');

  readln(d);

  writeln('Введите первый элемент');

  readln(a1);

  s:= ((2*a1+d*(n-1))/2)*n;

  writeln('Номер: ', n-1, '     Значение: ', a1+d*(n-2));

  writeln('Номер: ', n, '     Значение: ', a1+d*(n-1));

  writeln('Номер: ', n+1, '     Значение: ', a1+d*n);

  writeln('Сумма ', n, ' первых элементов равна: ',S);

end.

          

  

 

Ответить

Другие вопросы из категории

отметьте правильные ip адреса

a)192.168.1.1
b)12.23.1
c)272.23.34.31
d)1.12.256.1
e)192.168.0.257

Заполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [-10;10] и вывести на ее на экран.

Удвоить все элементы матрицы и вывести ее на экран.

Помогите пожалуйста в среде паскаль решить такую задачу:

посчитать сколько нечетных цифр в н - значном числе! (паскаль)

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "паскаль 1)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.