Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

нужно написать программу.введите с клавиатуры 2 числа а и в,если числа не равны,то замените каждое из них на 0 и выведите результатом на экран.если они

10-11 класс

равны,то найдите и выведите удвоенную сумму этих чисел

La25052003 22 нояб. 2014 г., 21:36:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lilia1999
22 нояб. 2014 г., 23:56:22 (9 лет назад)

var a,b:integer;

begin

readln(a,b);

if a<>b then begin a:=0; b:=0; writeln(a,' ',b); end else writeln(2*(a+b));

end.

+ 0 -
HumanHal
23 нояб. 2014 г., 1:05:28 (9 лет назад)

var
  a, b: real;  //Инициализируем 2 действительных переменных

begin
  writeln('Введите 2 числа');
  readln(a, b);  //Вводим 2 числа
  if a <> b then   {Если числа не равны, то присваиваем переменным нули и печатаем их, иначе печатаем удвоенную сумму этих чисел}
  begin
    a:= 0;
    b:= 0;
    writeln('a = ', a, ', b = ', b);
  end
  else writeln('2 * (', a, ' + ', b, ') = ', 2 * (a + b));
end.

Если все правильно, отметь решение как лучшее)

Ответить

Другие вопросы из категории

Составьте программу, которая :

а) Определяет коды двух введённых с клавиатуры символов;
б)Выполняет операцию сцепления трёх введённых с клавиатуры символов;
на Pascal

Читайте также

Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: А и В. Если числа не равны, то замените каждое из них большим и выведите

результаты на экран. Если они равны, то найдите и выведите удвоенную сумму этих чисел.

Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и

выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.

ПОМОГИТЕ ПОЖАЛУЙСТА!!!! Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените

каждое из них меньшим и выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.

Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу



Вы находитесь на странице вопроса "нужно написать программу.введите с клавиатуры 2 числа а и в,если числа не равны,то замените каждое из них на 0 и выведите результатом на экран.если они", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.