Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задача в паскале.

10-11 класс

Ввести натуральное число N. Проверить, расположены ли его цифры в порядке неубывания.
Решить НЕ ЧЕРЕЗ МАССИВ. (циклами)

MrStafford13045 17 июня 2013 г., 15:28:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krpchva
17 июня 2013 г., 16:48:09 (10 лет назад)

uses crt;
var
i,a,s,min:integer;
begin
write('vvedite 4islo: ');
read(a);
s:=0;
min:=a mod 10;
while a>=1 do
begin
i:=a mod 10;
a:=a div 10;
if i>min then
s:=s+1;
end;
if s>0 then
write('ne verno')
else
write('4islo zapisano verno');
read;
end. 
так пойдет?

+ 0 -
Света202
17 июня 2013 г., 18:06:33 (10 лет назад)

вывести yes или no?

+ 0 -
Vasilevadasha
17 июня 2013 г., 19:42:51 (10 лет назад)

да

Ответить

Другие вопросы из категории

Заданы два числа 56(8) и AF(16).

Переведите числа в двоичную систему счисления и выполните операции арифметического сложения и умножения, а также операции поразрядного логического сложения и умножения.
Правильность полученных результатов проверьте с помощью компьютерного калькулятора.

. Цветное (с палитрой

из 256 цветов) растровое графическое изображение имеет размер 10 х 10 точек.
Какой объем памяти займет это изображение?

Читайте также

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:

Решить задачу в Паскале:

Задать случайным образом 8
элементов числового массива – числа от 100 до 200. Вставить в него:

а) число «-20» перед 5-ым
элементом.

б) число «0» перед максимальным элементом. В одной задаче должно быть и а и б (но можно и по отдельности, главное, чтобы было верно)))

Нужно решить задачу в Паскале, условие таково:

"Найти наименьшее кратное двух чисел a и b"

Насколько я помню в этой задаче можно использовать команду Break.


Здравствуйте) помогите составить задачи по паскалю)

задачи на такую тему: Составление, ввод, трансляция и
исполнение программ, реализующих
циклические алгоритмы и типовые
операции с одномерными массивами

Помогите решить задачу на Паскале.

Дана строка.Перенести последнюю букву слова в начало слова



Вы находитесь на странице вопроса "Задача в паскале.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.