Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

почему pascal не может найти файл, пишет что файл не найден, хотя он есть!

10-11 класс

вот программа
Program ex1;
var:a,b,sum:integer;
f1,f2:text;
begin
assign(f1, 'input.txt');
assign(f2, 'output.txt');
reset(f1);
read(f1, a,b);
sum:=a+b;
rewrite(f2);
write(f2, sum);
close(f1);
close(f2);
end.

Tanya4156 03 мая 2015 г., 22:01:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Danyna
03 мая 2015 г., 23:49:38 (9 лет назад)

Он есть где?

Проверь название файла. Именно файла. Вдруг опечатка.
Попробуй ввести полный путь в тексте программы.
Посмотри есть ли русские буквы в пути к  файлу.
Если файл *.txt лежит не рядом с самой программой, положи его в папку с программой.
Или просто положи его в корень C и укажи путь в коде.

+ 0 -
Svetlan9
04 мая 2015 г., 0:21:43 (9 лет назад)

не может найти файл f1(input.txt)

Ответить

Читайте также

Почему Pascal не видит символ ";"?
1. Расширение файла, как правило, характеризует:

тип файла

программное обеспечение

название программы

2. Файл - это:

поименованный объект, расположенный на диске

поименованная совокупность байтов, размещенная на внешнем носителе

совокупность поименованных ячеек памяти

3. Задан полный адрес файла: c:\documets\prikaz.doc. Какое у файла составное имя?

prikaz.doc

documets\prikaz.doc

documets\prikaz

^ 4. К сервисным системам относятся:

интерфейсные системы

инструментальные системы

утилиты

программные системы

оболочки

^ 5. Какое программное обеспечение обеспечивает рабочую среду для других программ:

прикладное

системное

инструментальное

^ 6. Какая версия программного продукта является более новой:

MS DOS 6.0

MS DOS 6.20

MS DOS 6.22

7. Программы, скачанные из Интернета и имеющие определенный срок пользования, являются:

платными

бесплатными

условно-бесплатными

^ 8. Интерфейс, в котором для управления компьютером используются объекты, называется:

объектно-ориентированным

графическим

командным

^ 9. Программы, которые существенно меняют пользовательский интерфейс, не меняя при этом программный, относятся к:

утилитам

интерфейсным системам

оболочкам

^ 10. Какой шаблон позволяет найти файлы, которые начинаются на букву f, заканчиваются на t и имеют любое расширение:

*f????t.*

f*?d.*??

f?*d.*

^ 11. Сколько различных операционных систем можно установить на одном жестком диске:

только одну

только две

только три

12. Какое максимальное число логических дисков можно создать в расширенном разделе:

три

любое

23

13. После форматирования диска его доступный объем может уменьшиться по причине:

наличия на диске логических ошибок

наличия испорченных секторов

наличия фатальных ошибок

Производится двухканальная (стерео) звукозапись с частотой дискретизации 16 кГц и 24-битным разрешением, результаты записываются в файл, сжатие данны

х не используется. Размер файла с записью не может превышать 4 Мбайт. Какая из приведённых ниже величин наиболее близка к максимально возможной продолжительности записи?



Вы находитесь на странице вопроса "почему pascal не может найти файл, пишет что файл не найден, хотя он есть!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.