Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вводится произвольная последовательность целых чисел.найти наибольшее из всех чисел.

10-11 класс

Kristina1983 28 марта 2015 г., 7:19:23 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dashagudemchuk
28 марта 2015 г., 10:07:03 (9 лет назад)

На паскале
---
uses crt;
var a,b,max: integer;
begin
     writeln('Вводите последовательность. Окончание последовательности - 0.');
     readln(a);
     max:=a;
     while a<>0 do begin
           if (a>max) then max:=a;
           readln(a);
     end;
     writeln('Наибольшее число последовательности: ',max);
end.

+ 0 -
Pandora96
28 марта 2015 г., 12:09:04 (9 лет назад)

программа чтоль нужна?

+ 0 -
НатальяПавел
28 марта 2015 г., 14:26:27 (9 лет назад)

угу

Ответить

Читайте также

№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма

всех введенных данных чисел не будет равна 177. №2. Определите диаметр круга, радиус, площадь, если известна длина окружности L. №3.Даны два действительных числа А, В. Найти наибольшее из них и выяснить четное оно или нет.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.



Вы находитесь на странице вопроса "Вводится произвольная последовательность целых чисел.найти наибольшее из всех чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.