Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного

10-11 класс

пользователем.(Паскаль)

Zazatoo 14 февр. 2015 г., 9:56:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KatyaFam98
14 февр. 2015 г., 11:42:14 (9 лет назад)

a, b, i, s: integer;
begin
readln(a, b);
if (a > b) then
begin
s := a;
a := b;
b := s;
end;
s := 0;
for i := a to b do
if (i mod 2 = 0) and (i > 0) then
inc(s, i);
writeln(s);
end.

+ 0 -
Ronaldocr89
14 февр. 2015 г., 12:43:10 (9 лет назад)

Гарантируется что а < b?

+ 0 -
Jddifkhjggj
14 февр. 2015 г., 15:29:27 (9 лет назад)

нет

+ 0 -
ElizavetaУmnik
14 февр. 2015 г., 16:38:25 (9 лет назад)

тогда маленькая корректировка в решение

Ответить

Другие вопросы из категории

Информация,свойства информации
число,

представленное двоичным эквивалентом, перевести в число восьмеричного и шестнадцатеричного эквивалента 01110.10010

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

Помогите пожалуйста составить программу в Паскале: Дан

целочисленный массив из N элементов.
Вывести на экран сумму всех четных чисел
в этом массиве.

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент



Вы находитесь на странице вопроса "Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.