Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

У школьников было S рублей. Бутылка с соком стоит P рублей, пустая бутылка стоит B рублей.Напишите программу, вычисляющую, сколько бутылок сока могут

10-11 класс

выпить ученики, если они сдают пустые бутылки и на вырученные деньги и на деньги, оставшиеся от предыдущей покупки, покупают бутылки с соком. (На Паскале)

Татьяна20011 24 февр. 2017 г., 7:03:40 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Юляшкаi
24 февр. 2017 г., 8:47:35 (7 лет назад)

program zadacha_1;
var
  s, p, b : real;
  n : integer;
begin
  n := 0;
  writeln('Введите количество денег у школьника пример:(10.00)');
  read (s);
  writeln('Введите стоимость сока пример:(10.00');
  read (p);
  writeln('Введите стоимость бутылки пример:(10.00');
  read (b);
  while s>=p do
    begin
    n := n + 1;
    s := s - p;
    s := s + b;
    end;
  writeln('Можно купить ', n, ' бутылок сока.');
end.

Ответить

Другие вопросы из категории

переведите из 2 в 10 число 11111101
Два игрока играют в следующую игру. На координатной плоскости стоит фишка. Игроки ходят по очереди. В начале фишка находится в точке с координатами

(-2;1). Ход состоит в том, что игрок перемещает фишку из точки с координатами (х;у) в одну из трех точек (х+4;у); (х;у+3); (х+2;у+2). Выигрывает игрок, после хода которого расстояние по прямой от фишки до точки с координатами (0;0) не меньше 9 единиц. Кто выигрывает при безошибочной игре обоих игроков – игрок, делающий первый ход, или игрок, делающий второй ход? Каким должен быть первый ход выигрывающего игрока? Ответ обоснуйте.

Написать программу вычисления произведений в Паскаль 2*4*6*...*(2n).

ПОМОГИТЕ ПЛИЗЗЗ решить срочно

Как расшифровывается слово БОЛТРЕК?
Помогите пожалуйста!)

Читайте также

Задание #1

Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.

Задание #2
Напиши программу, вычисляющую стоимость покупки с учетом 10 %-й скидки, которая предоставляется только в том случае, если сумма покупки больше 1000 рублей.

Задание #3
Напиши программу, вычисляющую сумму всех четных чисел от 1 до N.

Задание #4
Напиши программу, вычисляющую среднее арифметическое заранее созданного массива случайных чисел из 10 элементов.

Задание 4. Студентам была предложена анкета о том, знание каких из прочитанных

курсов могут потребоваться в будущей работе. Результаты анкетирования были
занесены в файл. Напишите программу создания файла анкетирования. Список
прочитанных курсов:

Ребята, помогите пожалуйста!!!

У вас было а рублей, вы купили 10 тетрадей по в рублей, 1 дневник по с рублей и 3 ручкм по п рублей. Составить программу , выводящую количество вашей сдачи.,

Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было

введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.



Вы находитесь на странице вопроса "У школьников было S рублей. Бутылка с соком стоит P рублей, пустая бутылка стоит B рублей.Напишите программу, вычисляющую, сколько бутылок сока могут", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.