Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Что означает каждая из этих строчек..плииииз очень надо!!!!

5-9 класс

uses crt;

var i,j,n: integer;

begin
write('n=');
readln(n);

for i:=1 to n do

begin
for j:=1 to n do

if (i=1) or (i=n) then write(0) else

if (i<=j) and (i+j<=n+1) then write(1) else

if (i>=j) and (i+j>=n+1) then write(1) else

write(0);

writeln;

end;

readln;

end.

7241956 27 дек. 2013 г., 18:41:02 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ЗАЙКИКИСКИМИЛАШКИ
27 дек. 2013 г., 20:45:04 (10 лет назад)

ну uses crt для того если я не ошибаюсь что-бы работала программа
Var это переменные
Writeln это то что обычно будет написано программой
Readln это то число которое ты будешь вводить
дальше веселей скажу на своём
если i равно 1 или n тогда 
начали 
если j равно 1 или n тогда
если i равно 1 или i равно n написать 0 в противном случае
если i больше или равно j  и i+j меньше или равно n+1 тогда написать 1 в противном случае
если i меньше или равно j и i+j больше или равно n+1 тогда написать 1 в противном случае написать 0 

+ 0 -
Войненкова
27 дек. 2013 г., 23:06:02 (10 лет назад)

тебе всё объяснять

+ 0 -
Elenaatb
28 дек. 2013 г., 0:39:56 (10 лет назад)

нет,просто расписать каждую строчку,к примеру что означает первая строчка ,там допустим то то и то то.

+ 0 -
GladeatorO
28 дек. 2013 г., 1:35:21 (10 лет назад)

ну как-то так

Ответить

Другие вопросы из категории

Заданы значения a и b.Составить прогрвмму с помощью которой вычислить значение

функции a+b
R= ----------
a-b
для допустимых значений переменной.

РЕБЯТА СРОЧНО

СОСТАВЬТЕ СИНКВЕЙН СО СЛОВОМ КОМПЬЮТЕР
я тормоз и не знаю как;)

Читайте также

Помогите срочно! По информатике задали 7 вопрос: Возле школы растут шесть деревьев: сосна, берёза, липа, тополь, ель и клён. Какое из этих деревьев самое

низкое, если известно, что берёза ниже тополя, липа выше клёна, сосна ниже ели, липа ниже берёзы, сосна выше тополя?
И второй вопрос: Пятеро одноклассников - Аня, Саша, Лена, Вася и Миша - стали победителями школьных олимпиад по истории, математике, информатике, литературе и географии. Известно, что: 1) победитель олимпиады по информатике учит Аню и Сашу работе на компьютере; 2) Лена и Вася заинтересовались информатикой; 3) Саша всегда побаивался истории; 4) Лена, Саша и победитель олимпиады по литературе занимаются плаванием; 5) Саша и Лена поздравили победителя олимпиады по математике; 6) Аня сожалеет о том. что у неё остаётся мало времени на литературу.
Победителем какой олимпиады стал каждый из этих ребят?

Упражнение “О честности министров”. Условие: известно и истинно, что народу страны служат сто министров, и каждый из этой сотни либо продажен, либо

честен. Агентству национальной безопасности стало известно, что: (1) по крайней мере один из министров честен; (2) из любой пары министров по крайней мере один продажен. Вопрос: можно ли на основании этих утверждений решить, сколько министров продажны, а сколько - честны?

Жюри распределяло места в конкурсе песни. Один из членов жюри сказал: “Первое место я бы отдал песне “Поверь, мне тоже очень жаль”, а песне

“Любочка” - второе. Другой член жюри заметил: “Песне “Поверь, мне тоже очень жаль” я бы отдал второе место, а “песне “Школьная пора” - первое. Когда места были распределены, получилось, что в каждом из высказываний членов жюри одна часть оказалась верной, а другая - нет. Какие песни заняли первое и второе места в конкурсе.

В одной группе в летнем оздоровительном лагере оказались пятиклассники Аня, Боря, Гриша и Дина. У каждого из них есть одно из следующих увлечений:

рисование, танцы, пение,туризм , футбол. Певица решила подружиться с туристкой. Дина удивилась, узнав,что художник и туристка - брат и сестра. Гриша дружит с художником и танцором. У Васи нет сестёр. Назовите увлечения каждого из ребят.

помогите пожалуйста составить программу для этой задачи в паскале... уличный продавец газет получает a рублей с продажи каждой из первых 50 газет. С

продаж каждой из остальных газет он получает на 20% больше. разработайте программу,которая вычислит заработок продавца,если он продает за день 200 газет.



Вы находитесь на странице вопроса "Что означает каждая из этих строчек..плииииз очень надо!!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.