Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу на паскале по такому вот вопросу:

10-11 класс

"Вводиться 3 числа. Есть ли вероятность того, что одно из них оканчивается на 0?"

ктотаммо 13 февр. 2014 г., 8:25:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tema832
13 февр. 2014 г., 10:59:09 (10 лет назад)

var
  number1, number2, number3 : integer;
begin
  readln(number1);
  readln(number2);
  readln(number3);
  writeln('Вероятность есть');
end.

+ 0 -
Pugachirinka
13 февр. 2014 г., 13:00:41 (10 лет назад)

Ну получается берем сколько чисел оканчивается на 0 и делим 3, но почему тут не даны, к примеру, двухзначные, или трехзначные эти числа..

+ 0 -
Ксения203
13 февр. 2014 г., 15:23:11 (10 лет назад)

Если ограничения нет, то вспоминаем, что множество даже целых чисел несчетно

+ 0 -
12111994dima
13 февр. 2014 г., 17:36:28 (10 лет назад)

Вы не можете использовать статистику - не сказано, что число случайное. Я могу просто ввести 1 1 1.

+ 0 -
Jemako773
13 февр. 2014 г., 19:54:03 (10 лет назад)

И еще - датчик случайных чисел в Паскале и Бейсике реализован весьма неважно - у него распределение несколько отличается от равномерного. Так что серьезные задачи на их основе считать нельзя.

+ 0 -
Kimdimon
13 февр. 2014 г., 21:52:44 (10 лет назад)

Читайте по поводу датчиков монографию Д.Кнута.

Ответить

Другие вопросы из категории

1.Сколько секунд потребуется обычному модему,

передающему сообщения со скоростью 28800 бит/с, чтобы передать цветное растровое изображение размером 640Х480
пикселей при условии, что цвет каждого
пикселя кодируется тремя битами?

Скорость передачи данных через ADSL‑соединение равна 32000 байт/c.

Определите размер файла, который будет передан через 1 минуту. Ответ выразите в Кбайтах.

В ячейке D5 электронной таблицы записана формул. Эту формулу скопировали в ячейку C4. В результате знание в ячейке C4 вычисляется по формуле 3x+y, где x

- значение в ячейке C22, а y - значение в ячейке D22. Какая формула могла быть записана в ячейке D5?

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите написать программу на паскале по этой задаче.

Ввести 3 числа,найти их сумму,произведение и среднее арифметическое.

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!



Вы находитесь на странице вопроса "Написать программу на паскале по такому вот вопросу:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.