Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите найти количество простых цифр в паскале пожалуйста

10-11 класс

Nastyadal 05 апр. 2017 г., 10:33:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
15Анютка15
05 апр. 2017 г., 12:47:26 (7 лет назад)

Код Pascal1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 Program Prostiechisla; { Простые числа из промежутка [n; m] } uses WinCrt; var  n, m, i : integer;  {----------------------------------------------------------------------------------------} Procedure prostie(p : integer); var  i, k : integer; begin if p=2 then write(p, ' ') else if p mod 2 <> 0 then begin  i := 3; k := 0; while i <= trunc(sqrt(p)) do begin if p mod i = 0 then k := k + 1;  i := i + 2 end; if k = 0 then write(p, ' ') end end;  {----------------------------------------------------------------------------------------}       begin  write('Введите левую границу промежутка > 1 '); readln(n);  write('Введите правую границу промежутка '); readln(m);  writeln('Простые числа из промежутка [', n, ' ', m, ']'); for i := n to m do probleme_number(i);  writeln end.

Ответить

Другие вопросы из категории

Чтобы нарисовать при помощи лепестковой диаграммы правильную пятиконечную звезду в Microsoft Excel необходимо:

1) расположить в 10 ячейках чередующиеся числа 5 и 2 и по ним построить диаграмму
2) ввести в ячейки числа от 1 до 5 и по ним построить диаграмму
3)воспользоваться встроенной функцией ЗВЕЗДА
4)построение такой диаграммы не возможно

Integer8◦

. Дано двузначное число. Вывести число, полученное при переста-
новке цифр исходного числа.

Помогите найти число компьютеров в сети если,

IP адрес:192.168.1.2
маска подсети:255.255.255.0

решение уровнения A*x^2+B*x+C=0

Читайте также

Помогите пожалуйста решить задачи в турбо Паскале!

1) Определить количество двухзначных чисел, сумма цифр которых равна числу N.
2) Составить таблицу для двух столбцов выражения y=x²+3. Ввод чисел через клавиатуру.
3) Составить программу вычисления суммы кубов чисел от 1 до 5.
4) Вычислить сумму части ряда, 1/3, 1/6, 1/9, 1/12....
5) Среди двухзначных чисел, найти те, сумма цифр которых делятся на 3.
6) Найти самую большую цифру:
а) в двухзначном числе
б) трехзначном числе.

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

1. Дано n чисел. Найти колличество тех, которые делятся на 5, и не делятся на 7.

2. Найти квадраты всех отрицательных чисел среди N заданных.
3. Найти количество чисел, среди N введенных,которые имеют нечетные порядковые номера, а сами являются четными числам.
4. напишите программу для вычисления суммы:
- 1*1!+2*2!+3*3!+....+n*n!
- 1*3+3*5+5*7+...n(n+2)
- 1+11+111+...+111+1-n слагаемых.
Помогите, пожалуйста написать программы для паскаля, очень нужно. Заранее спасибо.

Помогите, пожалуйста!! Язык программирования Паскаль.

1) Найти количество отрицательных элементов в массиве А [3,8].
2) Заполнит и вывести массив Р [6,7], запросить номер строки и вывести её на экран.
3) Заполнить и вывести массив Р [6,7], запросить номер строки, заменить все её элементы на 5 и вывести новый массив.
4) В квадратной матрице А [10,10] заменить элементы главной диагонали на 0.

Всё нужно очень срочно



Вы находитесь на странице вопроса "помогите найти количество простых цифр в паскале пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.