Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

1. Дано n чисел. Найти колличество тех, которые делятся на 5, и не делятся на 7.

10-11 класс

2. Найти квадраты всех отрицательных чисел среди N заданных.
3. Найти количество чисел, среди N введенных,которые имеют нечетные порядковые номера, а сами являются четными числам.
4. напишите программу для вычисления суммы:
- 1*1!+2*2!+3*3!+....+n*n!
- 1*3+3*5+5*7+...n(n+2)
- 1+11+111+...+111+1-n слагаемых.
Помогите, пожалуйста написать программы для паскаля, очень нужно. Заранее спасибо.

Juliy7772011 30 янв. 2014 г., 7:19:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
тигранчикон
30 янв. 2014 г., 9:46:35 (10 лет назад)

Первая (N - количество чисел в исходной последовательности):

const N = 5;
var number, i, count : integer;
begin
    count := 0;
    for i := 1 to N do
    begin
        write('Input number: ');
        readln(number);
        if (number mod 5 = 0) and (number mod 7 <> 0) then
            count := count + 1;
    end;
    writeln('Count: ',count);
    readln;
end.

Вторая:

const N = 5;
var number, i, count : integer;
begin
    count := 0;
    for i := 1 to N do
    begin
        write('Input number: ');
        readln(number);
        if (number < 0) then
            writeln('Square of ',number,' equals ',number*number);
    end;
    readln;
end.


Ответить

Другие вопросы из категории

Для кодирования букв О, Л, А, З, К используются двоичные коды чисел 0, 1, 2, 3 и 4 соответственно (с сохранением одного незначащего нуля в случае

одноразрядного представления). Если таким способом закодировать последовательность символов ЗАКОЛКА и записать результат в шестнадцатеричном коде, то получится:
1) 4531253 2) 9876 3) E832 4) 238E
----------------------------
Помогите,пожалуйста! Желательно с кратким решением,потому что самой понять тоже хочется)

248062 бит = сколько мб?

Читайте также

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

Найти все числа, которые делятся на N среди

а) всех двузначных чисел;
б) всех трёхзначных чисел

Найдите наименьшее K, такое что K! делится на N без остатка. K!=1*2*3...*(K-1)*K

Форма входа данных : в первой и единственной строке дано число N (1= Формат выходных данных: Выведите наименьшее число K факториал которого делится на N.

Примеры A.in = 4 A.out = 4 A.in = 8 A.out = 4



Вы находитесь на странице вопроса "1. Дано n чисел. Найти колличество тех, которые делятся на 5, и не делятся на 7.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.