Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан номер года. Определить количество дней в этом году, если високосный год делится на 4, за исключением тех годов, которые делятся на 100 и не делятся на

10-11 класс

400. Решить нужно с помощью case.

German3770 08 авг. 2013 г., 4:14:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Дилявер
08 авг. 2013 г., 7:12:51 (10 лет назад)

program gt;
var n:longint;
begin
readln(n);
case n of
1..10000:  if(n mod 400=0)or((n mod 4=0)and(n mod 100<>0))then writeln('YEs')   else
writeln('NO');
end;
end.

Ответить

Другие вопросы из категории

У исполнителя Аккорд две команды, которым присвоены номера:1. отними 12. умножь на x(x – неизвестное положительное число)Выполняя первую из них, Аккорд

отнимает от числа на экране 1, авыполняя вторую, умножает это число на x.Программа для исполнителя Аккорд – это последовательность номеровкоманд.Известно, что программа 12121 переводит число 6 в число 119.Определите значение x.

Задача А Четные

N-Factorial - это произведение всех чисел от 1 до N.Для заданного числа N определите,сколько нулей в конце десятичной записи.
Формат входных данных

Читайте также

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.



Вы находитесь на странице вопроса "Дан номер года. Определить количество дней в этом году, если високосный год делится на 4, за исключением тех годов, которые делятся на 100 и не делятся на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.