Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана матрица А(m,n).Вычислите сумму тех элементов,которые делятся на 3 без остатка. Составьте, пожалуйста, программу!помогите .....

10-11 класс

Irinakrasinska 10 июня 2014 г., 3:06:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
исаева2002
10 июня 2014 г., 4:14:21 (9 лет назад)

var arr:array[1..100,1..100] of longint;
n, m, i, j, k:longint;
begin 
read(n, m); 
for i:= 1 to n do   
for j := 1 to m do     
begin     
read(arr[i][j]);     
if (arr[i][j] mod 3 = 0) then       
 k := k + arr[i][j];     
end;  writeln(k);
end.

Ответить

Другие вопросы из категории

Упростите логическое выражение: #g*h+g*#h+#g*#h до наиболее краткой формы.

(для обозначения инверсии используется знак # перед переменной, например, #h означает h с инверсией, для обозначения логического сложения и умножения используются знаки "+" и "*"

Читайте также

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

Помогите пожалуйста с информатикой(паскаль)

Посчитать сумму первых 10 чётных чисел.(те которые делятся на 2 без остатка)

Дано натуральное число N. Найти наименьшее число М (N < M < 2N) которое делится на сумму цифр числа N (без остатка). Если такого числа нет, то

вывести слово «нет». Пример. N = 12 345, М = 12360. Число 12 360 делится на число 15 — сумму цифр числа N



Вы находитесь на странице вопроса "Дана матрица А(m,n).Вычислите сумму тех элементов,которые делятся на 3 без остатка. Составьте, пожалуйста, программу!помогите .....", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.