Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Дано натуральное число N. Найти наименьшее число М (N < M < 2N) которое делится на сумму цифр числа N (без остатка). Если такого числа нет, то

10-11 класс

вывести слово «нет». Пример. N = 12 345, М = 12360. Число 12 360 делится на число 15 — сумму цифр числа N

Trezor78 28 янв. 2014 г., 6:17:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alesyapischalo1
28 янв. 2014 г., 6:54:15 (10 лет назад)

var M, N, sumN: integer;
begin
  readln(N);
  M := N;
  sumN := 0;
  while (M > 0) do
  begin
    inc(sumN, M mod 10);
    M := M div 10;
  end;
  M := (N div sumN + 1) * sumN;
  if (M < 2*N) then
    writeln(M)
  else
    writeln('нет')
end.



Ответить

Другие вопросы из категории

Что определяет технология SMART в жестких дисках?

(укажите несколько правильных ответов)


1) Считывание двух байт за один такт синхронизации по фронту и спаду синхроимпульса

2) Систему самодиагностики, анализа и оповещения об ошибках и критических ситуаций с жестким диском

3) кеширование жесткого диска

4) технология чтения данных с жесткого диска с их оцифровкой и определения максимальной вероятности по методу Витерби

5) технология чтения данных с жесткого диска по принципу определения пикового уровня намагниченности

какую часть экрана займёт изображения файла типа ВМР объёмом 3 Мбайт, созданного при глубине цвета, равного 32 бита, при разрешении экрана 1024×768 точек

и качестве цветопередачи 32 бита?
1)весь экран
2)1/2 экрана
3)1/3 экрана
4)1/4экрана
только по подробнее напишите пожалуйста с решением

Читайте также

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

1. Дано натуральное число n. Переставить его цифры так, чтобы образовалось максимальное число, записанное теми же цифрами.

2. Найти все двузначные числа, сумма квадратов которых делится на 17.

Всё это нужно сделать в программе Паскаль, но КАК?!

Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в К- ю степень( где К- количество цифр в числе) равна самому числу.

Например, 153=1³ + 5³ + 3³.
Входная строка содержит два натуральных числа- значения а и б.
Входные данные
Входная строка содержит два натуральных числа - значения а и б, разделенных пробелами. Гарантируется, что а≥б.
Выходные данные
Программа должна вывести в одну строчку все числа Армстронга на отрезке а, б, разделив их пробелами. если таких чисел нет, программа должна вывести -1.



Вы находитесь на странице вопроса "Дано натуральное число N. Найти наименьшее число М (N &lt; M &lt; 2N) которое делится на сумму цифр числа N (без остатка). Если такого числа нет, то", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.