Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составьте алгоритм решения квадратного уравнения в Паскале

5-9 класс

Kovtonyukandri 29 июня 2014 г., 14:48:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
DanKing1337
29 июня 2014 г., 15:24:17 (9 лет назад)

program alg;

var a, b, c, D, x1, x2 : real;

begin
  write('Введите a, b, c: ');
  readln(a, b, c);

  D := b * b - 4 * a * c;

  if (D >= 0) then begin
    if (D > 0) then begin
      x1 := (-b + sqrt(D)) / (2 * a);
      writeln(x1:0:2);
    end;
   
    x2 := (-b - sqrt(D)) / (2 * a);
    writeln(x2:0:2);
  end
  else
    writeln('Корней нет');
end.

Ответить

Другие вопросы из категории

помогите составить ребусы:

текстовый редактор
документ
курсор

1)Определите значение с после выполнения следующего фрагмента программы а:= 100; b:=30; а:= а-b*3; if a>b then c:= а-b

else с:= b-a;

2) Чнму равна сумма элементов а{1} и а{4} массива, сформированного следующим образом.

for i:= 1 to 5 a{i} :=i*(i+1)

Помогите, срочно!) НУЖНО СОСТАВИТЬ ПРОГРАММУ ВЫЧИСЛЕНИЯ. Для данного х вычислите у по формуле у=x^3+2,5^2-x+1. при этом а)оператор возведения в

степень использовать нельзя

б)в одном операторе присваивания не более одной арифметической операции(сложение, умножение, вычитание)

в) должно быть не более пяти операторов присваивания.

Подсказка (x+2,5)x-1)x+1

Помогите пожалуйста, желательно развернутый ответ

'Почему калькулятор нельзя назвать алгоритмической машиной, а компьютер можно?'



Вы находитесь на странице вопроса "Составьте алгоритм решения квадратного уравнения в Паскале", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.