Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

преобразования между значимыми и ссылочными типами: 1) всегда допустимы 2) никогда не допустимы 3) должны быть явными 4) могут быть неявными

10-11 класс

Oderiya 05 июля 2013 г., 10:15:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Velikayadaschulka
05 июля 2013 г., 11:22:48 (10 лет назад)

Безусловно, должны быть явными, потому что ни один из ссылочных типов не являтся подтипом значимых и преобразования должны быть заданы самостоятельно.

 

Ответ: 3)

Ответить

Читайте также

Все типы переменных, используемые в программе, написанной на

языке Паскаль, должны быть описаны в разделе типов, например, так:

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.

Program Frankenstein;
var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=r
then writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.

Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?

Дано задание "Составьте программу, определяющую, лежит ли точка с

указанными координатами X, Y на окружности радиуса R с центром в
начале координат." я её составил но почему у меня всегда получается что точка не лежит на окружности хотя она лежит. Может я где то ошибся ?

var


x,y,r:integer;


Begin


Write('Введите координату X: ');


Readln(x);


Write('Введите координату Y: ');


Readln(y);


Write('Введите длину радиуса R: ');


Readln(r);


If (sqr(x)+sqr(y))=r


then writeln('Точка лежит на
окружности!')


Else writeln('Точка не лежит на
окружности!');




End.



Вы находитесь на странице вопроса "преобразования между значимыми и ссылочными типами: 1) всегда допустимы 2) никогда не допустимы 3) должны быть явными 4) могут быть неявными", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.