Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

вычислить сумму всех четных натуральных чисел меньше данного n . задача по информатике

10-11 класс

Аня142 07 дек. 2013 г., 10:26:07 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
VetaLeta
07 дек. 2013 г., 11:15:23 (10 лет назад)

СLS
INPUT n
FOR i = 1 TO n
IF INT(i/2) = i/2 THEN s=s+i
NEXT i
PRINT "сумма равна"; s
END

+ 0 -
Сергей1534567
07 дек. 2013 г., 12:18:24 (10 лет назад)

Не указан ЯП.

+ 0 -
Vikany
07 дек. 2013 г., 14:11:07 (10 лет назад)

program summa;

+ 0 -
Lunora
07 дек. 2013 г., 16:27:19 (10 лет назад)

var i,n,k:integer;
begin
readln(n);
for i:=1 to n do
if i mod 2 = 0 then inc(k,i);

writeln('Sum=',k);
end.

Ответить

Другие вопросы из категории

Привести примеры свойств информации (по одному на каждого)

1. Объективность информации
2. Необъективность информации
3. Достоверность информации
4. Недостоверность информации
5. Полнота информации
6. Неполная информация
7. Актуальность информации
8. Неактуальность информации
9. Ценная информация
10. Не ценная информация
11. Понятная информация
12. Непонятная информация

в память фотоаппарата к ней добавляетсяслужебная информация о дате, месте и

параметрах съемки. Эта информация
занимает ровно 24 КБайта. Фотоаппарат
позволяет снимать как одиночные
фотографии, так и серии из трех фотографий
с различными параметрами диафрагмы. В
таких сериях указанная выше служебная
информация добавляется только к первой
фотографии, а к последующим фотографиям
серии присоединяется только служебная
информация об изменении диафрагмы, в
объеме ровно 8 КБайт на каждую.

Юный фотограф
сделал несколько одиночных фотографий
и несколько серий, его фотографии имели
разрешение 2048 на 1360 точки и глубину
цвета 24 бита. Фотографии сохраняются
без сжатия. Другой информации кроме
самих фотографий и описанной служебной
в памяти нет. Какое максимальное
количество одиночных фотографий мог
сделать фотограф, если известно, что
серий ровно в 3 раза меньше, чем одиночных
фотографий, а сохраненный объем данных
не превышает 192 МБайт? В ответе укажите
целое число.

помогите...

составить таблицу истинности для логического выражениЯ

_ ____
А ∧ В ∨ (А∧В)

Читайте также



Вы находитесь на странице вопроса "вычислить сумму всех четных натуральных чисел меньше данного n . задача по информатике", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.