Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Сформируйте массив из 10 элементов, каждый элемент которого равен сумме значений его индекса и квадрата индекса. Найдите произведение элементов массива,

10-11 класс

стоящих на четных местах. Вывести на экран эти элементы и их произведение.

Nastya5597 23 сент. 2014 г., 10:13:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maometto1979
23 сент. 2014 г., 11:51:09 (9 лет назад)

var a:array[1..10] of integer;

p,i:integer;

Begin

  p:=1;

  for i:= 1 to 10 do begin

    a[i]:=i+i*i;

    if odd(i) then begin

      writeln(a[i]);

      p:=p*a[i];

    end;

  end;

  writeln(p);

End.

+ 0 -
Sanek2090
23 сент. 2014 г., 14:05:02 (9 лет назад)

var

a : array[1..10] of intenger;
b : intenger;
Begin

b:=1;

For i:= 1 to 10 do

 begin

a[i]:=i+i*i;

end;
For i:= 1 to 5 do
begin
b:=b*a[i*2];
end;
 For i:=1 to 5
begin
Writeln(' ',a[i*2]);
end;
 Writeln('произведение элементов массива, стоящих на четных местах=',b);

End.

Ответить

Другие вопросы из категории

Помогите пожалуйста очень срочно))

Закодировать фразу "Делай всё вовремя!" КОИ-8; СР-1251. Подсчитайте объем видеопамяти для хранения одного изображения в 16 цветов с расширением 1280х1024 пиксилей.

ХОТЯ БЫ ОБЪЯСНИТЕ КАК РЕШИТЬ! ОЧЕНЬ НАДО! НУ ВСЕ ПУНКТЫ ЧТО ЕСТЬ ОТДАЮЮЮЮЮ Тело брошено

вертикально вверх со скоростью 40 км/ч. Найти значение проекции скорости этого тела в течении 6 секунд, через каждые 0,5 секунд


Надо решить в электронной таблице HELP PLEASE!

Читайте также

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов

от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и произведение отриц.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива



Вы находитесь на странице вопроса "Сформируйте массив из 10 элементов, каждый элемент которого равен сумме значений его индекса и квадрата индекса. Найдите произведение элементов массива,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.